网络工程吧

网络工程吧

【范文精选】网络工程吧

【范文大全】网络工程吧

【专家解析】网络工程吧

【优秀范文】网络工程吧

范文一:网络工程1

1. 以下IP地址中,不属于私有地址的是

C (A) 10.10.10.2 (B) 192.168.10.3 (C) 172.168.0.4

(D) 10.0.0.1

2. SNMP是通过B 协议来传输消息的。 (A) TCP (B) UDP

(C) ICMP (D) ARP

3. 常用的双绞线是由C 绞线组合而成 (A)1对(B)2 对(C)4 对

4. 下列TCP/IP协议中,不属于应用层协议的是

B (A) OSPF (B) RARP (C) TFTP (D) FTP

5. 路由选择是A 的基本功能。 (A) 网络层 (B) 数据链路层

(C) 传输层 (D) 应用层

6. 在计算机信息系统中,TCP/IP协议栈属于

C (A) 管理平台 (B) 系统平台 (C) 传输平台 (D) 网络平台

7. 在综合布线系统中,终端设备到信息插座的连线部分通常被称为

B (A) 设备间子系统 (B) 工作区子系统 (C) 水平子系统 (D) 垂直干线子系统

8. 要实多个不同的网络之间的通信连接,我们需要借助

B (A) 网桥 (B) 路由器 (C) 交换机 (D) 集线器

9. 下列Internet应用中,基于C/S计算模式的是

A (A) FTP (B) BTC (C) MSN (D) Skype

10. 下列有关LLC子层的叙述,正确的是 (A) LLC子层是物理层的一个子层 (B) 各种不同的以太网技术采用了不同的LLC子层 (C) LLC子层提供了面向数据帧的传输控制 (D) LLC子层与传输媒体具有紧密联系

11. 下列编码中,不属于自同步编码的是

A (A) 不归零制编码 (B) 曼彻斯特编码 (C) 差分曼彻斯特编码 (D) 以上均不是

12. 在下列各种CSMA技术中,发送帧前侦听总线遇到“忙”时,将随机等待一段时间后再次侦听总线是否处于“忙”状态的是

C 。 (A) 1-坚持CSMA (B) p-坚持CSMA (C) 非坚持

CSMA (D) 以上均不是

13. 区分独立基本服务集与Infrastructure基本服务集的主要依据是服务集中是否包含了 B (A) 分发系统 (B) 接入点(AP) (C) 无线介质

(D) 工作站

14. 路由表中“0.0.0.0/0”所代表的是C(A) 动态路由 (B) 通过RIP协议获得的路由 (C) 缺省路由 (D) 无法识别的路由

15. 下列协议中,可以将IP地址转换为MAC地址的是

B (A) RARP (B) ARP (C) DNS (D) ICMP

16. 下列关于地址转换技术(NAT)的叙述,不正确的是 B (A) 地址转换技术可以使使用私有IP地址的内部主机访问Internet (B) 地址转换技术能够确保内部主机正常使用所有Internet服务 (C) 地址转换技术能够对内部主机起到一定的安全保护作用 (D) 以上均不正确

17. 下列协议中,用于解决电子邮件中传输多语言文字和附件问题的是 A 协议。 (A) MIME (B) SMTP (C) SNMP

18. 下列关于全双工以太网技术的叙述,不正确是B (A) 全双工以太网技术可以提高网络带宽 (B) 全双工以太网技术能够有效控制广播风暴 (C) 全双工以太网技术可以延伸局域网的覆盖范围(D) 以上均不正确

19. TCP/IP参考模型中的网络接口层(Network Access)对应了OSI参考模型中的 B (A) 网络层 (B) 数据链路层和物理层 (C) 数据链路层 (D) 物理层

20. 下列关于IP协议中分段与重组的叙述,不正确的是A (A) IP协议可以对所有的分组进行分段 (B) 分段后的IP分组具有相同的标识符 (C) 分段后的IP分组的总长度将超过分组前的长度 (D) 以上均不正 1、

局域网通信选用的通信媒体通常是专用的同轴电缆,双绞线和光缆与无线信道。 2、 ATM 是一种面向连接的快速分组交换技术。 3、 中继器具有完全再生网络中传送的原有物理信号的能力。 4、 国内最早的四大网络包括原邮电部的ChinaNet、原电子部的ChinaGBN、教育部的CERnet (或中国教育科研网) 和中科院的CSTnet。 5、 根据制作工艺不同,双绞线可分为非屏蔽双绞线(UTP)和屏蔽双绞6、 路由器在7层网络参考模型各层中涉及 网络层。7、10BASE-T标准规定的网络拓扑结构是星型或总线型,网络速率是 10Mbps,网络所采用的网络介质是双绞线, 信号是 。 8、 局域网软件主要由网卡驱动程序和网络协议两个基本部分组成。 9、 广播式通信信道中,介质访问方法有多种。IEEE802规定中包括了局域网中最常用3种,包括

CSMA/CD、Token bus token ring。 10、 ATM可能达到的网络传输速率是 51.84Mb/s。 11、 token bus 的媒体访问控制方法与其相应的物理规范由 IEEE802.4标准定义。 12、 FDDI可能达到的网络速度是100Mbps。 13、 IEEE802局域网体系结构中,数据链路层被细化成逻辑链路子层和介质访问控制子层两层)两大类

1、什么是计算机网络?能提供哪些服务? 计算机网络,是指将地理位置不同的具有独立功能的多台计算机及其外部设备,通过通信线路连接起来,在网络操作系统,网络管理软件及网络通信协议的管理和协调下,实现资源共享和信息传递的计算机系统。 计算机网络的功能主要表现在硬件资源共享、软件资源共享和用户间信息交换三个方面。 (1)硬件资源共享。可以在全网范围内提供对处理资源、存储资源、输入输出资源等昂贵设备的共享,使用户节省投资,也便于集中管理和均衡分担负荷。 (2)软件资源共享。允许互联网上的用户远程访问各类大型数据库,可以得到网络文件传送服务、远地进程管理服务和远程文件访问服务,从而避免软件研制上的重复劳动以及数据资源的重复存贮,也便于集中管理。 (3)用户间信息交换。计算机网络为分布在各地的用户提供了强有力的通信手段。用户可以通过计算机网络传送电子邮件、发布新闻消息和进行电子商务活动。

2、简述什么是计算机网络的拓扑结构,有哪些常见的拓扑结构? 计算机网络的拓扑结构,即是指网上计算机或设备与传输媒介形成的结点与线的物理构成模式它的结构主要有星型结构、环型结构、总线结构、分布式结构、树型结构、网状结构、蜂窝状结构等。

4、什么是路由器?路由器的主要功能是什么? 路由器是一种连接多个网络或网段的网络设备,它能将不同网络或网段之间的数据信息进行“翻译”,以使它们能够相互“读”懂对方的数据,从而构成一个更大的网络。 路由器有两大

典型功能,即数据通道功能和控制功能。数据通道功能包括转发决定、背板转发以及输出链路调度等,一般由特定的硬件来完成;控制功能一般用软件来实现,包括与相邻路由器之间的信息交换、系统配置、系统管理等。

1. 以下IP地址中,不属于私有地址的是

C (A) 10.10.10.2 (B) 192.168.10.3 (C) 172.168.0.4

(D) 10.0.0.1

2. SNMP是通过B 协议来传输消息的。 (A) TCP (B) UDP

(C) ICMP (D) ARP

3. 常用的双绞线是由C 绞线组合而成 (A)1对(B)2 对(C)4 对

4. 下列TCP/IP协议中,不属于应用层协议的是

B (A) OSPF (B) RARP (C) TFTP (D) FTP

5. 路由选择是A 的基本功能。 (A) 网络层 (B) 数据链路层

(C) 传输层 (D) 应用层

6. 在计算机信息系统中,TCP/IP协议栈属于

C (A) 管理平台 (B) 系统平台 (C) 传输平台 (D) 网络平台

7. 在综合布线系统中,终端设备到信息插座的连线部分通常被称为

B (A) 设备间子系统 (B) 工作区子系统 (C) 水平子系统 (D) 垂直干线子系统

8. 要实多个不同的网络之间的通信连接,我们需要借助

B (A) 网桥 (B) 路由器 (C) 交换机 (D) 集线器

9. 下列Internet应用中,基于C/S计算模式的是

A (A) FTP (B) BTC (C) MSN (D) Skype

10. 下列有关LLC子层的叙述,正确的是 (A) LLC子层是物理层的一个子层 (B) 各种不同的以太网技术采用了不同的LLC子层 (C) LLC子层提供了面向数据帧的传输控制 (D) LLC子层与传输媒体具有紧密联系

11. 下列编码中,不属于自同步编码的是

A (A) 不归零制编码 (B) 曼彻斯特编码 (C) 差分曼彻斯特编码 (D) 以上均不是

12. 在下列各种CSMA技术中,发送帧前侦听总线遇到“忙”时,将随机等待一段时间后再次侦听总线是否处于“忙”状态的是

C 。 (A) 1-坚持CSMA (B) p-坚持CSMA (C) 非坚持

CSMA (D) 以上均不是

13. 区分独立基本服务集与Infrastructure基本服务集的主要依据是服务集中是否包含了 B (A) 分发系统 (B) 接入点(AP) (C) 无线介质

(D) 工作站

14. 路由表中“0.0.0.0/0”所代表的是C(A) 动态路由 (B) 通过RIP协议获得的路由 (C) 缺省路由 (D) 无法识别的路由

15. 下列协议中,可以将IP地址转换为MAC地址的是

B (A) RARP (B) ARP (C) DNS (D) ICMP

16. 下列关于地址转换技术(NAT)的叙述,不正确的是 B (A) 地址转换技术可以使使用私有IP地址的内部主机访问Internet (B) 地址转换技术能够确保内部主机正常使用所有Internet服务 (C) 地址转换技术能够对内部主机起到一定的安全保护作用 (D) 以上均不正确

17. 下列协议中,用于解决电子邮件中传输多语言文字和附件问题的是 A 协议。 (A) MIME (B) SMTP (C) SNMP

18. 下列关于全双工以太网技术的叙述,不正确是B (A) 全双工以太网技术可以提高网络带宽 (B) 全双工以太网技术能够有效控制广播风暴 (C) 全双工以太网技术可以延伸局域网的覆盖范围(D) 以上均不正确

19. TCP/IP参考模型中的网络接口层(Network Access)对应了OSI参考模型中的 B (A) 网络层 (B) 数据链路层和物理层 (C) 数据链路层 (D) 物理层

20. 下列关于IP协议中分段与重组的叙述,不正确的是A (A) IP协议可以对所有的分组进行分段 (B) 分段后的IP分组具有相同的标识符 (C) 分段后的IP分组的总长度将超过分组前的长度 (D) 以上均不正 1、

局域网通信选用的通信媒体通常是专用的同轴电缆,双绞线和光缆与无线信道。 2、 ATM 是一种面向连接的快速分组交换技术。 3、 中继器具有完全再生网络中传送的原有物理信号的能力。 4、 国内最早的四大网络包括原邮电部的ChinaNet、原电子部的ChinaGBN、教育部的CERnet (或中国教育科研网) 和中科院的CSTnet。 5、 根据制作工艺不同,双绞线可分为非屏蔽双绞线(UTP)和屏蔽双绞6、 路由器在7层网络参考模型各层中涉及 网络层。7、10BASE-T标准规定的网络拓扑结构是星型或总线型,网络速率是 10Mbps,网络所采用的网络介质是双绞线, 信号是 。 8、 局域网软件主要由网卡驱动程序和网络协议两个基本部分组成。 9、 广播式通信信道中,介质访问方法有多种。IEEE802规定中包括了局域网中最常用3种,包括

CSMA/CD、Token bus token ring。 10、 ATM可能达到的网络传输速率是 51.84Mb/s。 11、 token bus 的媒体访问控制方法与其相应的物理规范由 IEEE802.4标准定义。 12、 FDDI可能达到的网络速度是100Mbps。 13、 IEEE802局域网体系结构中,数据链路层被细化成逻辑链路子层和介质访问控制子层两层)两大类

1、什么是计算机网络?能提供哪些服务? 计算机网络,是指将地理位置不同的具有独立功能的多台计算机及其外部设备,通过通信线路连接起来,在网络操作系统,网络管理软件及网络通信协议的管理和协调下,实现资源共享和信息传递的计算机系统。 计算机网络的功能主要表现在硬件资源共享、软件资源共享和用户间信息交换三个方面。 (1)硬件资源共享。可以在全网范围内提供对处理资源、存储资源、输入输出资源等昂贵设备的共享,使用户节省投资,也便于集中管理和均衡分担负荷。 (2)软件资源共享。允许互联网上的用户远程访问各类大型数据库,可以得到网络文件传送服务、远地进程管理服务和远程文件访问服务,从而避免软件研制上的重复劳动以及数据资源的重复存贮,也便于集中管理。 (3)用户间信息交换。计算机网络为分布在各地的用户提供了强有力的通信手段。用户可以通过计算机网络传送电子邮件、发布新闻消息和进行电子商务活动。

2、简述什么是计算机网络的拓扑结构,有哪些常见的拓扑结构? 计算机网络的拓扑结构,即是指网上计算机或设备与传输媒介形成的结点与线的物理构成模式它的结构主要有星型结构、环型结构、总线结构、分布式结构、树型结构、网状结构、蜂窝状结构等。

4、什么是路由器?路由器的主要功能是什么? 路由器是一种连接多个网络或网段的网络设备,它能将不同网络或网段之间的数据信息进行“翻译”,以使它们能够相互“读”懂对方的数据,从而构成一个更大的网络。 路由器有两大

典型功能,即数据通道功能和控制功能。数据通道功能包括转发决定、背板转发以及输出链路调度等,一般由特定的硬件来完成;控制功能一般用软件来实现,包括与相邻路由器之间的信息交换、系统配置、系统管理等。

范文二:网络工程师

络工网程师

1)熟T悉P/IC协议和P网络构

结2)精通由器协路E议GRPIOS、P、BFGP的置配与调。 试

)精3通交换网中络的VT、PTS以P及三层换等交术技。

4)能 熟练运B用P MGLSPVPN、/网链路络余(冗HSR)P管理与的置配网络访、的控制与问置(AC配LN、ATPAT、/RM-A)P。

5)熟悉操作C ICS、O为、H华3C等路器由熟练;作JU操NPIERFO、RIGTTAESO、ICWNAL、LNESTRCENE防火墙等设。备

)熟练6作WIN操OWDS操作系的统装、安护和维全。 安

7)练熟操LIN作U操X系统作了解D,S,FTN,IPPATBELS等

8等)了解驻用常传输的术技:SDH,SMT等等,熟练P作华操的为MTEO10R00 。

9)有C拥CP证书优先。 N10)

了IP电话解基本理原了,常解用的TGM、AM设G备软交及平换台

2、网熟/络话布线、电维护故及障理处,熟练理处电软脑硬、件故,熟悉障公办设故备检障查和本基维。

护、精通3indoWw 系统的安s装和置配L,INU操X作系统相关常及用命。 令

、熟4AD悉的管理域维与护。深理刻TC解PI/协议P邮件,理原,DN,SDCHP。 等

、熟5架设常练的服务器用如,TFPpostfi,,xWB,E毒服务病器

等、对数6据备,份统系安全病毒,防有护深刻认和识富丰经验。

7性格、朗,工开作真认责任,强心,有好的良服观务念

描述位

.负1责内局域部网护维 ;

2.行进务器、服由器路、电交换话等设机备管理以,及络网平台运的监行控和维护 ;

3.负责司公监控系的统常维护日和修维

4.;行进办设公的备日维护及管常;技术理档案护;维

5.责病负的查毒,杀护网络系统维安全 ;

.6处理络及计网算机障故;

7 .负责域、网站名维、后护数据、台邮箱理管等。

位职要求:

3.配置和管有wi理200n服务器、3Liunx务器经验服; 4

对.uJnpeir防墙有简火管单理验经先优

5.;精通用使常用办公软,件如软微关O相ficefphot、sooph产品;等

.良好6团队的作协意识能够主动不,断习新学知

、 1科,本算计技机、通术类相信关专业; 2、 熟

悉CSCI产品,O持有CNACC及CPN证书; 3、 一

或年上以络通讯行业网作工验;

4经、精 网通络术,技有具ANW系统目项实操作施计及管划经验,理独立完能成统系安实施全案方 ;

5 、大型有网系统络、防墙火Ci、cso交换及路由器机等品安产、维装护经验 ;

6、熟 使悉用络网析分具及时处理工各种见故常障 ;

7、具 良好的备通组沟织能,力责心强 任 ;

8 、适能经应常出差或被分派需广州到上或海作工 ;

9、能 流操利广话东优先

作内:容1

、划、规设、搭计、建维整护网络个系统

2、建;骨干网络立统系,并行检查进维护和;3

建、立网络扑拓、PI划分布规、布系统等线文资档料

,及时按要撰求写更、工新作及术技文;档

、负责对4网障碍的分络,析及处理时和决解络网出中的问现题;

5、负对整责系统个的网中流络量行监进控;6、

维护骨网络的干全安

岗要位求

1:熟、悉P服务器H、Csco路i器、由交机、Ju换niep防r墙、F5火等网络设的备硬件结构工、原理作;

、2掌握网络了平台相关技的术,,负载如衡平、统备系等;

份、良3好的互网联、域广和局域网网知;识

4充、理分TCP解I/P协议;

5熟、掌握练网工络以具速迅断诊、位定和排网除故络。

任职求要:1

、计机算或理工类关专业,相大及专以学上,历具有2以年大中上网站型维运工经验;作

2 精通L、inxuW和ndoiws作操日和维护常熟悉,Lnuxi+pache/nginA+PxP+MyHqs网l站构,架能熟练置配

A

pahec/PHP/MSQLy/DN S/amba/NSS/BiFdn/FPT/aiM等开源软l应件; 用

3

熟悉网站、全安范防及攻原理击,熟能悉 ptaibes l等火墙配防置;

、熟悉4TC/PPI协议常及用络网应用,悉网络架构熟,熟练握掌服务器、由路器、火防、墙交换等机网设络备的硬软知识件,备基本具网的络故障错排能,对网络力全有安定一了的解;

5掌、握ySML语Q法操作及 ;

6

具备负载均衡、大网站型集群架、设载均衡负相关等验者优经先。

7、人正直,工作态品度真认负责,有较好的队协团作和沟通力能有,烈强的任责及良心的编好程习惯能,应较适的工强作力压。

岗职责位:

负互联网责信监控息作工

负责控监据的整理分数

任职析要:求

1计算机相、专业关本学历;科

2、熟互悉联的网作及操使用,够能练熟用使联互搜网引擎,熟索练使用SM ffice软o;件3

熟、防悉墙火、DIS、PI等网络S安设全,并备能够分析和发现网络安全备哦设志日中产所的异常状生况;

招条件:

. 大专1上学以历,2年以上网络维经验护

2 有.强较的沟能通力,任心责,有强团队神精

3. 具备主

流作操统及系网方络的知面识体

4 .悉计算熟硬件机

5

.熟 操练L作ux系n及统AML环境P

位岗职:责

1.

负责网络及 系的日统常理和维管护,硬件备维设护

.2 负责网络安管理工全

作3 负责.部内域网络局维护进,服务器行、路由、交换器等设备机理管,及网以络平台的监控维护和

4 负责病毒.查杀,维护网络的系安全,处理网统及络算机计障故

. 负5维护打责印机,理内部管集电团话交换机

。. 6负公司软件责产技术支品与配合。持

. 7负责企网业站务器服维护、数更新、据份。备

1、规医院基础划络网构架2;设、并计组织院的医统和网系络设建;

职要求位:1、本及以科上学历计算,、网络机相关

专业2;五、以年大中上企业型络管网理验; 经

3、熟微悉软、LINU操X作系统;熟目悉主流前网技络,术掌握类网络协议各4、;具备RAOCL、SQL ESRVERE等大数据型库管的理维与护验经,够独能立进大型数据行库的理与管维护作;工

、5练掌握网络和熟计算机安装的置配和试,调够提能解决硬供件统和系件软统系题的问解决方案 ;6

熟,网络设备、服悉务、小型器的安装、机试、调护;熟维计算悉机网和络络安全的网试调具;网络故障备分的、判断、解决能力;析

7、通C过CA和NCMES认证其或相他认证关者优考先;虑

8、有良的好队合团意作识性、开朗,格于沟通善、责任心、强务意服强识;

、9作细工、心极积主、推动动力、有强较的强业务文件编制力能

位职 责

1、业企内建设和管网理;行进网络构架规划的设、、计调、性能优整;

2化网、络境环管的,配置,理排错,维护;

3、络网设备安的装、置、管配,理提网供设络备维方案护;

4、网 络安全网,络量质网及络备设监的,生成控网络量报表; 质

5建立、整完的网络统文系档

6、协助办公网络环;的境护维,端设终备维的。 护

任资职:格

日全制正规校院毕业本科及以,上历学,通类、信息信、类电类、子算机计类关专业相

有具年以2网上络管工作经理验

熟悉网基础络知,识熟T悉C/PP

I熟掌握路由练器交、机安装配换置(icco、saclatle、H3CNo、rtle一以种上

熟)掌练Vlan握STP、Tru、k、nRRP、VSHP、ORSFP常用路等由交换技

术熟悉流主防墙火c(ehcpokni、Jtnupir)e配,熟置V悉P、NPS、IDI技术

S具备CCP、NCCIE证者书先优

系统工师程

301以岁下计算;、机通信、信息程相关专工,业专大以学上;历 2

.能用英够阅读文技文档,术能够用粤语沟通者使先;优

.1年以上客户3场现支工持经作验,有具好的程序良用分析应能;力

.熟练掌握4AVJ语言A及开其发境,特环别熟悉是SJ、PServel的开发t与用应熟,悉tSurts、iHbrneaetS、rinpg等用框架应具备W,ebogilcJ、oBss、Weshbee等J2rE应E用服务开器发经者验先;

优.5解了Oracae、SlQLSrveeer大型数据等库

6了.解thmlj、vaasrcpi、tcss等ebw页技术网.

系统

集成工师程

岗职责位

、1负系责集成项统目设的与计划,规实施方案及的拟订

2、系统;成集项目的组管织与项理目实;

施、产品性3、能维运系的统优和化进改

4、;现产发问品题,出优提秀的解方案决;

5、决集解成术难题技调查与,掘挖客需求,提户出针对性的解决方案; 有

、6定编写投制文档标项目方案书、行业、技术文档;

、负7责招投标程过组中和技织术作工。

任职格 资1、

算机计、子电本科类学历 ;

2、有年一以上关工作相经验;

、熟3配练置换机交、路由、器服务器网、服络务等;

、4解相关了发语言开,数据库操作和统知识系 ;5

具有较、好的技术文档制编能力,好良英语沟的通能力;

、6强较的表能力及达客与户通沟力,良能的好分问析题和际动手实力,良能的学习好创和新能力 ;

、7任心责,强有具敬业团、合队精作,能神经出差。常

范文三:网络工程论文

《网络工程导论》课程学习心得体会

及个人职业生涯规划

年 级 大一

学 院 合肥学院南艳湖校区

专 业 网络工程

班 级 二班

学 号 1104032004

姓 名 戴超

任课教师 袁暋

完成时间 11月11日

成 绩

(报告在给出成绩的同时须由评阅人写出评语)

年 月 日

 内容摘要:

1) 对本专业的认识,即本专业在IT领域中位置及能解决的主要问题;

2) 本专业涉及的主要知识、设置的主要课程及在大学四年中的分布;

3) 本专业今后主要就业方向及岗位需要的知识、能力和素质;

4) 本人今后就业目标;

5) 根据该目标制定四年学习计划及职业生涯规划。

 关键字:我和网络工程

我今天演讲的论文题目是网络工程学习心得体会和个人职业生涯规划。我将课程体系和对网络工程的认识放在前半部分,将压轴的职业生涯规划放在后面。

但在开始我的论述之前我想讲述一下自己入校的经历,现在实行平行志愿,但我还是把合肥学院放在我的D志愿。在填征集志愿那天四点我才发现自己被合肥学院网络工程专业录取,这是网络工程第一次引起我注意。其实那天我已经做好准备填征集志愿,而且从上海回家的车票都买好了。

在导论课上,我了解了网络工程的框架,和未来就业的方向。第二次导论课,我们实地参观了学校网络系统中心,想象那些双绞线中传递的信息,想象自己将要揭开网络神秘的面纱,心里还有了些许自豪。在听了袁老师关切的话语,我感觉到老师对导论课的重视,体会到老师对我们给予的希望。所以接下来我想介绍一下我在课后收集,课上积累的成果。并举出例子让抽象变得具体。

 对网络的认识

什么是网络,网络原指用一个巨大的虚拟画面,把所有东西连接起来,也可以作为动词使用。在计算机领域中,网络就是用物理链路将各个孤立的工作站或主机相连在一起,组成数据链路,从而达到资源共享和通信的目的。凡将地理位置不同,并具有独立功能的多个计算机系统通过通信设备和线路而连接起来,且以功能完善的网络软件(网络协议、信息交换方式及网络操作系统等)实现网络资源共享的系统,可称为计算机网络。网络会借助文字阅读、图片查看、影音播放、下载传输、游戏聊天等软件工具从文字、图片、声音、视频,等方面给人们带来极其丰富和美好的使用和享受。

 对网络工程的认识

网络工程专业是指按计划进行的网络综合性工作。本专业培养掌握网络工程

的基本理论与方法以及计算机技术和网络技术等方面的知识,能运用所学知识与技能去分析和解决相关的实际问题,可在信息产业以及其他国民经济部门从事各类网络系统和计算机通信系统研究、教学、设计、开发等工作的高级科技人才。网络工程专业的特色主要在于以网络通信技术和计算机技术为基础,突出计算机软硬件系统、数字通信系统、计算机网络系统、网络安全技术和网络管理技术,使本专业培养的学生具有适应网络通信和计算机两方面专业领域的能力。

 网络工程师的技能要求

网络工程分为硬件工程和软件工程。相信大家都已经知道我们学院是应用型的学校,主要培养应用型和工程型的人才。所以对技能一:网络设备的设计与制造技术。技能二:网路协议的设计与实现技术。技能三:网络应用系统的设计与开发技术,技能四:网络系统的规划设计与施工技术,等技能要求比较高。通过了解专业和所需技能,接下来我们就要了解本专业课程体系。并对你的课余时间和学习时间进行合理规划。

 网络工程的课程设置

对于网络工程课程设置,虽然我没经历过,具体课程会上哪些内容也不清楚,但我觉得基础是必须强调的。它是整栋大楼的地基,决定你是否能应对未来遇到的狂风暴雨。所以基础课的主要课程体系包括:

1、公共基础课程: 主要包括高等代数、大学物理、英语、体育、政治理论、计算机文化基础、C语言 等课程。

2,专业基础课程:线性代数、概率论、电路分析基础、电子电路基础、电子线路CAD、电子技术实验、电子技术课题设计、离散数学、汇编语言程序设计、计算机组成原理与系统结构、单片机原理、接口技术、操作系统原理、数据结构、面向对象程序设计、计算机网络、现代通用技术、数据库原理、计算机图形学、编译原理、科技英语等。

我认为这些基础课都应该在大一和大二上学期熟练掌握,为更高层次的学习做铺垫。到了大二下学期和大三这些基础课程结束后就是专业课的接触,同时牵涉到必修和选修,所以一定要看好市场行情和个人兴趣爱好决定你的未来发展方向。既要广泛学习又要在某一方面有突出表现。

3、专业课程:网络设备、综合布线技术、网络的组件与设计、计算机安全技术等课程。

4、专业选修课:根据你的定位找到适合自己的专业,如JAVA和数据库。

5、实践类课程:指导师的指导下,进行网络管理、网络安全、网络系统集成、网络营销综合训练,以检验、巩固所学的专业知识。

这里我会把握好实践机会,展现自己的特长,同时在实践中发现自己的不足,完善自己同时学习课本中没有的知识。通过自己努力掌握解决实际问题的方法途径。其实我也挺期待自己在实践课中的表现。

通过掌握常用操作系统的使用、网络设备的配置,深入了解网络的安全问题,具有综合性的网络管理能力。

虽然这些专业枯燥又难学,但我相信我能把他们学好。这里我还要强调一点就是专业素质和个人道德素养,在现在尔虞我诈的竞争市场,却存在人才紧缺问题,不仅因为大学门槛降低导致人才的专业素质降低,还因为个人素质参差不齐。所以在我们完成教学任务的同时,积极丰富自己的课余生活,培养良好的个人情操。这样我们才有和别人竞争的优势。

 我的职业生涯规划

接下来我想介绍一下我的人生规划,没有什么事是绝对的,所以我的职业生涯规划一定会在实践中完善,实践中进步。

在大学里,我会在业余时间丰富自己的兴趣爱好,这是我在进入大学之前就准备好的。跆拳道不一定要考中级,把身体素质提高一点就足够了。大一阶段我会尽力不挂科,不挂考,减轻以后的压力。争取英语过四级,和六级。完成必修课。对于选修课我会偏好网络安全方面,具体哪些课程我也不清楚。

我是一个比较我对未来工资要求比较高,但我会脚踏实地一步步迈向自己的目标。我的性情内向、保守而安静,沉着、温和而从容,不热衷于交际,是一个极富神秘色彩的人。对于熟人我表现的比较幽默风趣,但在陌生人中间我则会选择安静。我喜欢隐藏内心的热情,往往不逊于任何人,我比较像曹操,多疑遇到事情的时候欠果断,逞强好胜又不乏勇气与坚韧,与外表是截然不同的两种风貌。一旦面临挑战,我会立刻表现出令人意想不到的另一面,发挥自己的机智,我最无法忍受平凡一生的生活,所有我的职业生涯会比较曲折。对于网络工程其实我觉得我更适合做心理医生,因为我常常在猜别人的心思,在考虑事情发生的人为因素。我的优点很多,缺点也不少,喜欢捉弄人之类吧。其他就不多说了,下面是我的职业生涯规划,我的目标领域是网络安全。所以我将我的职业生涯分为三个阶段。

1. 第一阶段

根据自己的能力,找一家中小型企业就职,这是我职业生涯的开始,这里一般有网络基础设施管理,网络操作系统管理,网络应用系统管理,网络用户管理,网络安全保密管理,信息存储备份管理和网络机房管理可以供你选择。我则会选择网络安全保密管理,因为我对网络安全比较感兴趣。我认为第一职业重要,它不仅关系到你对未来工作岗位的信心,而且也是你对未来发展方向的定位。所以一定要慎重。在这片天空下,我们可以尽显自己的才华,无论是口才还是专业素

质。取长补短,在实践中完善自己的操作能力。培养更丰富的工作经历。同时,不要忘了与时俱进,了解市场变化,继续自己的深造之路。如果想进入高层这也是你接触底层劳动者的绝佳之际。当然我不可能就停留在这第一阶段,根据实际情况我会选择随时进入第二阶段,找到更能展现自己才华的企业。

2. 第二阶段

当我选择的是换工作环境,我将开始选择大中型企业。因为这样既能有更多空间展示自己,培养更丰富的经验,又能了解高层。工作在网络公司,大中型企业,在网络公司中主要任务:设计并建设,大中型企业中的主要任务:运营和维护,网络工程师其实是一个包括许多种工种的职业,不同的网络工程师工种对从业的人员的要求也不一样,对从业人员的网络管理水平的要求差别很大。专业网络工程师主要有:网络系统设计师、网络工程师、系统工程师、网络安全工程师、数据存储工程师、综合布线工程师。一样我会选择网络安全工程师,我更喜欢成为一名黑客,想象如果没有黑客,会有多少网络工程师下岗。

3. 第三阶段

第三阶段是专家级,比如技术主管、项目经理、技术专家。这个阶段因为太遥远所以变化肯定比较大,所以我不打算详细介绍。我觉得我会根据自己当时的能力,在任何机遇来临时,抓住他。所以可能我第二阶段就开始自己创业了。

想要完成这些阶段都意味着我们要不停地学习,既要在已学的领域内做出业绩,又要开辟新的领域。所以勤奋家汗水是必不可少的。在完成这些职业阶段之间,我会选择找准市场机遇,开始自己的创业之旅还是继续职业生涯。总的来说的职业生涯规划给了未来相当大的空间,应为我相信,计划永远赶不上变化。所以每个阶段所需的时间我没有划分,因为那都是纸上谈兵,“时间才是检验真理的唯一标准!”

最后我想感谢袁老师这些日的辅导,感谢同学的帮助,特别是我的兄弟连。 谢谢!

 参考文献:

1. 《计算机网络》第四版 谢希仁著。

2. CCNA学习指南中文版(第六版)

 参考网站: www.net130.com www.cisco.com

范文四:网络工程导论

《网络工程专业导论》课程学习心得体会及个人职业生涯规划

课程论文

论文名称 《网络工程专业导论》课程学习心得体会及个人职业生涯规划

班 级 11级网络工程1班

专 业 网络工程

学 号 1104031028

姓 名 辛成

任课教师 袁暋

完成时间 2012年02月26日

成 绩

目录

1) 对网络工程的认识

1) 主要课程以及其主要课程在大学中的安排及发展方向

3)今后的就业岗位及自己的就业目标

4)对于该目标应掌握的能力

5)培养能力应该制定的计划

6) 最后的总结及感想

1) 对网络工程的认识

网络工程是指按计划进行的网络综合性工作。

它包括:硬件工程和 布线工程 是一项实践性比较强的专业,

专业偏重硬件工程:硬件工程:是指计算机网络所使用的设备(交换机、路由器、防火墙、服务器等),工程包括网络的需求分析、网络设备的选择、网络拓扑结构的设计、施工技术要求等; 本专业培养的人才具有扎实的自然科学基础、较好的人文社会科学基础和外语综合能力;能系统地掌握计算机网和通信网技术领域的基本理论、基本知识;掌握各类网络系统的组网、规划、设

计、评价的理论、方法与技术;获得计算机软硬件和网络与通信系统的设计、开发及应用方面良好的工程实践训练,特别是应获得较大型网络工程开发的初步训练;本专业是专门为网络领域人才市场供不应求的迫切需要而设置的专业。

本专业主要学习网络工程的基本理论和技术,接收严格的网络系统工程训练,具有本学科及跨学科的应用系统设计、集成、应用开发的基本能力和较强的自我学习能力及知识更新能力。

2) 主要课程以及其主要课程在大学中的安排及发展方向 网络工程主要学习课程及大学四年分布

网络工程专业在大学四年主要学习专业主要课程有:高等数学、线性代数、概率论与随机过程、数学建模与模拟、组合数学、运筹学、形式语言与自动机、排队论、电路与电子学基础、数字逻辑与数字系统、离散数学、计算机导论与程序设计、算法与数据结构、计算机组成与系统结构、操作系统、数据库系统原理、软件工程、面向对象分析与设计、接口技术与汇编语言、嵌入式系统、信号与系统、计算机网络、通信导论、通信原理、现代交换原理、现代通信网、网络工程、信息与网络安全、接入网技术、宽带无线通信网络、通信软件设计、Internet技术等。

发展方向

(1) 管理员

是一个比较初级的工作,工作于基础设施管理、网络操作系统管理、网络应用系统管理、网络用户管理、网络安全保密管理、信息存储备份管理和网络机房管理等。

1、网络本身的管理;

2、网络中操作/应用系统的管理

待遇不高(初级)

(2) 网络工程师 网络工程师其实是一个包括许多种工种的职业,不同的网络工程师工种对从业的人员的要求也不一样,对从业人员的网络管理水平的要求差别很大。专业网络工程师主要有:网络系统设计师、网络工程师、系统工程师、网络安全工程师、数据存储工程师等。

(1)、公司需要建设网络,主要根据要求进行设计。

(2)、设计项目达到全面、高的实用性和可用性。

(3)、网络系统设计师是一个综合性的工种。

(4)、网络和系统方面都有很好的经验。

待遇一般

(3) 网络工程专家

进行专业的工作技术性的工作

(1)、融合技术和管理的复合性人才

(2)、参与项目谈判

(3)、项目目标和项目财务指标

(4)、划分工作内容并合理分配

待遇很高。(一般很难达到)

(4) 技术主管

技术全面;有管理能力

(1)、带领技术团队创造更多的价值

(2)、在信息方面参与公司的规划和计划

具有领导能力的人物,能决定一个企业或一个单位的发展(顶端人物)

3)4)本人今后就业目标

我觉得自己比较适合做网络系统安全方面的网络工程师,首先是自己从小就对网络有着浓厚的学习兴趣,再之,小时候上网会经常碰到烦人的病毒入侵,每当那时候我都束手无策,请专业人员到家来帮忙查修。那时候就挺羡慕那些专业人员,按照熟悉的套路敲几行代码就能够是你的电脑起死回生。再大一些,就会经常看那些黑客论坛,也深深的被黑客们精湛的技术所吸引,因此,我在决定今后目标的时候选择了网络系统安全的网络工程师

4)对于该目标应掌握的能力

明确职业目标:成为一名网络工程师。

首要目标:了解网络工程师的含义。首先,网络工程师有好多,就路线而言,有:路由交换型、无线型、布线型等。

就认证而言,有:华为认证 、中国的软考,cisco认证 、锐捷认证等网络工程师认证.

5)培养能力应该制定的计划

根据以上可知,网络工程师的含义大概就是利用互联网和数据交换设备来管理和控制设备,而其中也可分为路由型,无线型和布线型。虽然有三种类型,但是均可适用于不同规模的公司和企业内部网,其中,路由交换型使用的网络类型最为广泛,因此,我可以以此为主攻方向。但仍要掌握其他路线类型的技能。

现今中国有关网工方面的企业公司属华为,思科最为强势,并且相关度很大。其中,思科公司是最为理想的就业平台。首先,其主流产品就是生产路由器和交换机等网络设备。并且其提供的网络解决方案是全球使用最多的,这就意味着他需要大量的网络工程师为其提供方案。并且,思科的理念是以买断最新产品为主,

即使不能加入其公司,通过为其提供网络解决方案等也可达到就业效果,为自己提供发展平台。

初步就业目标:获得思科认证的网络工程师证书,并以进入思科为第一目标。(只有树立更高的目标,才能达到更高的高度)即使不能进入思科之类的大公司,也必须以专业对口为准则,学以致用,选择与网络工程有关的职业,同时也可以兼任一些电脑售后服务的职位,因为这样可以提高对各种客户端服务器的配置要求,有利于自己主要专业的发展。

寒假目标:利用寒假时间,熟悉VISTA系统各种配置,详细了解该系统的各种属性。熟悉掌握TCP/IP内容与各种流程。

未来一年目标:首先根据全国网络工程师考试纲要中的要求,熟练掌握各种网工的基础知识,并且把握机会多进行些动手实验。(详细内容见网工考试要求) 尽量多熟悉一些主流的操作系统,首先就要熟悉掌握自己电脑的操作系统,然后在掌握其他的。

多接触一些不同类型的路由器和交换机,以丰富阅历,多了解一些有关的硬件设施。

请教学校老师,多多了解网络工程的专业课内容,并请教该以学习何内容为主,以提前做好准备和节省时间。

三年内目标:获得英语四级证书,提高有关计算机网络方面的专业英语。国家软考的初级网络工程师的证书,如有可能,努力拿下CCNA证书。

毕业后五年目标:以网络工程师专业为准则,选择苏州的一家中小型网络公司,也可选择网络售后服务专业为辅助专业。

6)最后的总结及感想

既然选择了这个专业,我就有理由有动力要求自己去奋斗,去朝着自己的未来拼搏。

短暂的学习调查,或许不能让我全面地去了解网络工程,但却进一步提升了对它的认识,让我明白了网络工程是干什么的,要学什么,未来的就业前景如何。

知道了这些,我便有了一个轮廓性的了解,综合个人情况便有了对个人职业生涯规划,有了规划,便有了为了这个目标而采取的步骤。认真执行四年规划,相信大家会有一个不错的结果。

我相信只要我努力了,我付出了。就一定会有一个美好的为未来,我要在上机操作中掌握真的知识,在实习中掌握真的本领。在失败中吸取教训、汲取经验。不放弃,不抛弃。同时因为这个专业的进步性和潮流性。我们不能闭关造车,要把握社会和该专业的发展,争取做到最好。

这个社会是个竞争的社会,我们只有掌握真正的本领,才能在这个社会立足,才能有一份自己的天空。

因此我们更需努力,努力,再努力!

范文五:网络工程概论

网络工程

网络工程是指按计划进行的网络综合性工作。本专业培养掌握网络工程的基本理论与方法以及计算机技术和网络技术等方面的知识,能运用所学知识与技能去分析和解决相关的实际问题,可在信息产业以及其他国民经济部门从事各类网络系统和计算机通信系统研究、教学、设计、开发等工作的高级科技人才。计算机网与通信网(包括有线、无线网络)的结合是本专业区别于其他高校网络工程专业的显著特色。 目录

展开

编辑本段网络工程

网络工程分为:硬件工程 和 布线工程

硬件工程:是指计算机网络所使用的设备(交换机、路由器、防火墙、服务器等),工程包括网络的需求分析、网络设备的选择、网络拓扑结构的设计、施工技术要求等;

网络工程

布线工程:也称综合布线,它的目的是为了保持正常通讯而使用光缆、铜缆将网络设备进行连接。工程包括线缆路由的选择、桥架设计、线缆及接插件的选型等;

网络是一个非常大的概念,网络主要是指计算机网络系统。以分组交换技术为核心的计算机网络,自20世纪70年代以来得到了飞速发展.采用TCP/IP体系结构的Internet得到广泛使用.

为了使得网络能够适应基于网络的多种多样服务在带宽,可扩缩性和可靠性等方面不断增长的需求,网络工程必须应付这些挑战,解决好网络的设计,实施和维护等一系列技术问题.

1)有非常明确网络建设的目标,这在工程开始之前就确定,在工程进行中不能轻易更改。

2)工程有详细的规划,规划一般分为不同的层次,有的比较概括(如总体规划),有的非常具体(如实施方案)。

3)工程要有正规的依据,例如国际标准,国家标准、军队标准、行业标准或是地方标准。 编辑本段网络工程学科

作为一门学科,网络工程必须总结并研究与网络设计,实施和维护有关的概念和客观规律.从而使无论是刚刚涉足该领域的新手,还是久经沙场的老将,都能够根据这些概念和规律来设计和建造满足客户需求同时跟得上Internet发展步伐的计算机网络未来.

本专业培养掌握网络工程的基本理论与方法以及计算机技术和网络技术等方面的知识,能运用所学知识与技能去分析和解决相关的实际问题,可在信息产业以及其他国民经济部门从事各类网络系统和计算机通信系统研究、教学、设计、开发等工作的高级科技人才。计算机网与通信网(包括有线、无线网络)的结合是本专业区别于网络工程专业的显著特色。

2)工程有详细的规划,规划一般分为不同的层次,有的比较概括(如总体规划),有的非常具体(如实施方案)。

3)工程要有正规的依据,例如国际标准,国家标准、军队标准、行业标准或是地方标准。 编辑本段专业特色

网络工程专业的特色主要在于以网络通信技术和计算机技术为基础,突出计算机软硬件系统、数字通信系统、计算机网络系统、网络安全技术和网络管理技术,使本专业培养的学生具有适应网络通信和计算机两方面专业领域的能力。 编辑本段培养目标

本专业培养系统地掌握计算机、通信和网络方面的基本理论、知识和技能,并能运用所学知识去分析和解决相关的实际问题,可在信息产业、国防以及其他国民经济部门从事计算机通信系统和

网络工程

计算机网络及协议的研究、设计和开发,从事计算机网络管理、计算机网络安全研究的高级工程技术人才。使学生成为知识面广,具有一定创造能力的研究应用型专门人才。 编辑本段培养要求

本专业学生主要学习计算机、通信以及网络方面的基础理论、设计原理,掌握计算机通信和网络技术,接受网络工程实践的基本训练,具备从事计算机网络设备、系统的研究、设计、开发、工程应用和管理维护的基本能力。

毕业生应获得以下几方面的知识和能力:

1.具有扎实的自然科学基础、较好的人文社会科学基础和外语综合能力;

2.系统地掌握计算机和网络通信领域内的基本理论和基本知识; 3.掌握计算机、网络与通信系统的分析、设计与开发方法;

现代信息网络办公师、计算机维修工程师、网络管理员、 售后服务工程师、综合布线工程线、技术支持工程师

监理工程师、操作系统工程师、网络架构工程师、网络安全工程师、网络工程师、网站维护工程师、 网站设计开发工程师

计算机维修工程师

本专业学生毕业后可以从事各级各类企事单位的业办公自动化处理、计算机安装与维护、网页制作、计算机网络和专业服务器的维护管理和开发工作、动态商务网站开发与管理、软件测试与开发及计算机相关设备的商品贸易等方面的有关工作。[1] 编辑本段可考证书

(1)汉字录入师

(2)现代信息网络办公师 (3)国家教育部(NIT)证书 (4)计算机维修工程师 (5)计算机硬件装调师

(6)程序设计师(VB方向) (7)网络综合布线工程师 (8)网络工程与管理师

(9)数据库开发师(VFP方向) (10)网络安全管理维护师

(11)网页设计师 (12)平面设计师 (13)动画制作师

(14)国家劳动部计算机职业资格证书(中级) (15)动态网页设计师 (16)SQL数据库维护师

(17)网站开发架构师(ASP. NET+SQL)

第一模块(公共模块):现代信息网络办公师

第一部分:从零起步,学习计算机基础知识、汉字输入法、windows XP操作系统

第二部分:熟练掌握Office办公软件(Word文字处理、Excel电子表格、Powerpoint电子演示、并能够熟练的使用常用办公设备,如:打印机、扫描仪、刻录机、数码相机、网络摄像头等。

第三部分:熟练的运用和掌握Internet网络技术,如网络连接、信息浏览查询、上传下载、收发电子邮件、网络通讯等。 第二模块:计算机维修工程师

第一部分:掌握计算机基本组成、硬件识别、整机拆装、BIOS参数设置等。

第二部分:多媒体电脑组装维修调试和网络与通信基础。 第三模块:网络工程师

第一部分:信息网络工程师

网络工程与综合布线(网络拓扑、网络互联设备、网络组建与调试、网络工程预算及招、投标),智能楼宇、宽带网络;WIN2003网络操作系统、IIS设置以及各种服务器的设置与管理技术。 第二部分:高级网络工程师

路由技术及TCP/IP协议、WINDOWS高级管理技术(活动目录)和ISA网络安全管理。

第四模块:网站设计与维护师

第一部分:网站设计与维护师

通过学习“网页设计及网站建设、网站规划设计”掌握静态网站的设计制作技术和网站的规划建设;除学习传统的网站设计知识外,还要学习最新的DIV技术及综合素质课等

第二部分:网站设计与维护师拓展课程

通过学习Photoshop达到专业图片处理优化水平。 通过学习Flash动画达到职业“闪客”水平。

范文六:网络工程论文

网络工程综合实验

课程设计

题 目 路由协议在组网技术中的应用

院 系 电子工程系

专 业 信息工程

学 号 20092309022

姓 名 杨 金 磊

指导教师 王丽娜

二O一一 年 十二 月 八 日

目 录

一、摘要 ................................................. 3

二、原理简介 .......................................... 4

2.1交换机原理 .................................... 4

2.2路由器简介 .................................... 4

2.2.1 RIP协议 .......................... 4

2.2.2 OSTF协议 .......................... 5

三、实验设计 .......................................... 5

3.1 实验目的 ....................................... 5

3.2 实验背景 ....................................... 5

3.3 实验内容 ....................................... 6

3.4 实验设备 ....................................... 6

3.5 实验步骤 ....................................... 7

四、总结部分及参考文献 ........................ 2

摘要:

随着因特网技术的快速发展,因特网正在人们的日常生活中起到了越来越大的作用。网络技术的发展也极大地推动了企业网和校园网的建设,无论企业网还是校园网的建设对于企业和学校来说都是一项大的工程,必须精心设计、精心施工,做到经济适用,技术先进、开放性能良好、投资强度合理、与国内外网络互联、能长期、稳定运行的高性能的企业网络。目前在组网中各种动态路由协议和算法都已经比较成熟,各种动态路由协议都有各自的优缺点,应用特性和领域都各有不同。本文主要基于动态路由协议在组网技术中的研究。

关键词:

网络技术 动态路由 组网 企业

Summary:

With the rapid development of Internet technology, the Internet is people's daily life has played a growing role. Network technology has greatly promoted the development of the enterprise network and campus network

construction, whether corporate or campusnetwork construction for businesses and schools are a big project, must be carefully designed, well construction, so affordable advanced technology, opening up good performance, reasonable investment intensity, and domestic and international networking,long-term, stable operation of high-performance enterprise networks. Present in a variety of networking protocols and dynamic routing algorithms have been more mature, a variety of dynamic routing protocols have their own advantages and disadvantages, features andareas of application are different. This paper is mainly based on dynamic routing protocolin network technology research.

Keywords:

dynamic routing network enterprise network technologies

一、 原理简介

1. 交换机原理:假设两个使用IP协议的站点A、B通过第三层交换机进行通信,发送站点A在开始发送时,把自己的IP地址与B站的IP地址比较,判断B站是否与自己在同一子网内。若目的站B与发送站A在同一子网内,则进行二层的转发。若两个站点不在同一子网内,如发送站A要与目的站B通信,发送站A要向“缺省网关”发出ARP(地址解析)封包,而“缺省网关”的IP地址其实是三层交换机的三层交换模块。当发送站A对“缺省网关”的IP地址广播出一个ARP请求时,如果三层交换模块在以前的通信过程中已经知道B站的MAC地址,则向发送站A回复B的MAC地址。否则三层交换模块根据路由信息向B站广播一个ARP请求,B站得到此ARP请求后向三层交换模块回复其MAC地址,三层交换模块保存此地址并回复给发送站A,同时将B站的MAC地址发送到二层交换引擎的MAC地址表中。从这以后,当A向B发送的数据包便全部交给二层交换处理,信息得以高速交换。由于仅仅在路由过程中才需要三层处理,绝大部分数据都通过二层交换转发,因此三层交换机的速度很快,接近二层交换机的速度,同时比相同路由器的价格低很多。它是一个带有第三层路由功能的第二层交换机,但它是二者的有机结合,并不是简单地把路由器设备的硬件及软件叠加在局域网交换机上。

2. 路由器原理:路由器是工作在IP协议网络层实现子网之间转发数据的设备。路由器内部可以划分为控制平面和数据通道。在控制平面上,路由协议可以有不同的类型。路由器通过路由协议交换网络的拓扑结构信息,依照拓扑结构动态生成路由表。在数据通道上,转发引

擎从输入线路接收IP包后,分析与修改包头,使用转发表查找输出端口,把数据交换到输出线路上。转发表是根据路由表生成的,其表项和路由表项有直接对应关系,但转发表的格式和路由表的格式不同,它更适合实现快速查找。转发的主要流程包括线路输入、包头分析、数据存储、包头修改和线路输出。路由协议根据网络拓扑结构动态生成路由表。IP协议把整个网络划分为管理区域,这些管理区域称为自治域,自治域区号实行全网统一管理。这样,路由协议就有域内协议和域间协议之分。域内路由协议,如OSPF、IS-IS,在路由器间交换管理域内代表网络拓扑结构的链路状态,根据链路状态推导出路由表。域间路由协议相邻节点交换数据,不能使用多播方式,只能采用指定的点到点连接。

3. RIP(Routing information Protocol)是应用较早、使用较普遍的内部网关 协议(Interior Gateway Protocol,简称IGP),适用于小型同类网络,是典型的距离向量(distance-vector)协议。RIP通过广播UDP报文来交换路由信息,每30秒发送一次路由信息更新。RIP提供跳跃计数(hop count)作为尺度来衡量路由距离,跳跃计数是一个包到达目标所必须经过的路由器的数目。如果到相同目标有二个不等速或不同带宽的路由器,但跳跃计数相同,则RIP认为两个路由是等距离的。RIP最多支持的跳数为15,即在源和目的网间所要经过的最多路由器的数目为15,跳数16表示不可达。

RIP v2 由 RIP v1 而来,属于 RIP 协议的补充协议,主要用于扩大 RIP 2 信息装载的有用信息的数量,同时增加其安全性能。RIP 2 是一种基于 UDP 的协议。在 RIP2 下,每台主机通过路由选择进程发送和接受来自 UDP 端口520的数据包。

4. OSPF是一种分层次的路由协议,其层次中最大的实体是AS(自治系统),即遵循共同路由策略管理下的一部分网络实体。在每个AS中,将网络划分为不同的区域。每个区域都有自己特定的标识号。对于主干(backbone)区域,负责在区域之间分发链路状态信息。这种分层次的网络结构是根据OSPF的实际提出来的。当网络中自治系统非常大时,网络拓扑数据库的内容就更多,所以如果不分层次的话,一方面容易造成数据库溢出,另一方面当网络中某一链路状态发生变化时,会引起整个网络中每个节点都重新计算一遍自己的路由表,既浪费资源与时间,又会影响路由协议的性能(如聚合速度、稳定性、灵活性等)。因此,需要把自治系统划分为多个域,每个域内部维持本域一张唯一的拓扑结构图,且各域根据自己的拓扑图各自计算路由,域边界路由器把各个域的内部路由总结后在域间扩散。这样,当网络中的某条链路状态发生变化时,此链路所在的域中的每个路由器重新计算本域路由表,而其它域中路由器只需修改其路由表中的相应条目而无须重新计算整个路由表,节省了计算路由表的时间。

5.RIP与OSPF协议的比较

目前应用较多的路由协议有RIP和OSPF,它们同属于内部网关协议,但RIP基于距离矢量算法,而OSPF基于链路状态的最短路径优先算法。它们在网络中利用的传输技术也不同。

二、 实验设计

1. 实验目的

掌握配置动态路由的方法,以进一步理解路由器在互联网络中的应用。对路由器转发数据包的过程也可以得到进一步的理解。

2. 实验背景

Internet是由千千万万个路由器互联在一起进行工作的,网络中每一台路由器都运行着种动态协议,以不断学习整个Internet的拓扑结构,更新自身的路由表,使得收到的数据包能收到合适的路径。因此,了解并学会配置路由器的动态协议是一个网络管理员的必修课。为了简化起见,在本实验中,将使用3台路由器来连接3个网络,实现3个网络之间的互联。本实验可设定192.168.1.0为总部的网络号,Router A为该网络的辩解路由器;192.168.2.0为分部1的网络号,Router B为该网络边界路由器;192.168.3.0为分部2的网络号,Router C为该网络的边界路由器。Router A与Router B间的网络其网络号为192.168.4.0;Router A与Router C间的网络其网络号为192.168.5.0.

3. 实验内容

⑴配置动态路由协议RIP实验。

⑵配置动态路由协议OSPF实验。

4. 实验设备

3台计算机,3台路由器,3台交换机,2条DTE/DCE串口线缆,若干跳线。

5. 实验步骤

5.1动态路由协议RIP配置实验

(1)关闭所有路由器电源,按照如图所示的实验拓扑图连线,并配置好各台计算机的IP地址及网关。

Switch B

Router C

F1/0

GW:192.168.1.1 F0/16 (PC2)

Switch C IP:192.168.2.11/24

GW::192.168.2.1 GW:192.168.3.1

动态路由拓扑图

在图中,每台计算机的串口(COM)线都需要连到各自对应的路由器的Console端口上。每台计算机配置各自连接的路由器,小组中每个人合理分工,分别扮演A、B、C角色。

(2)配置Router A的端口IP及动态路由。将PC1的串口线连到Router A的Console端口上,打开PC1的超级终端,配置好参数,进入到路由器的普通模式,然后在其命令行窗口上输入以下黑色斜体字命令。

Router>enable

Password:

Router# conf t

Router(config)#hostname RouterA

RouterA(config)#interface f1/0

RouterA(config-if)#ip address 192.168.1.1 255.255.255.0

RouterA(config-if)#no shutdown

RouterA(config-if)#interface s1/2

RouterA(config-if)#ip address 192.168.4.1 255.255.255.0

RouterA(config-if)#no clock

RouterA(config-if)#no shutdown

RouterA(config-if)#interface s1/3

RouterA(config-if)#ip address 192.168.5.1 255.255.255.0

RouterA(config-if)#clock rate 64000

RouterA(config-if)#no shutdown

RouterA(config-if)#exit

Router(config)#ip routing

Router(config)#router rip

Router(config-router)#network 192.168.1.0

Router(config-router)#network 192.168.4.0

Router(config-router)#network 192.168.5.0

Router(config-router)#end

RouterA#show interface brief

Router A各端口参数配置情况

(3)配置Router B的端口IP及动态路由。将PC2的串口线连到Router B的Console端口上,打开超级终端,配置好参数,进入到路由器的普通模式,在其命令行输入窗口上输入以下命令。

Router>enable

Password:

Router#conf t

Router(config)#hostname RouterB

RouterB(config)#interface f1/0

RouterB(config-if)#ip address 192.168.2.1 255.255.255.0

RouterB(config-if)#no shutdown

RouterB(config-if)#interface s1/2

RouterB(config-if)#ip address 192.168.4.2 255.255.255.0

RouterB(config-if)#clock rate 64000

RouterB(config-if)#no shutdown

RouterB(config-if)#exit

RouterB(config)#ip routing

RouterB(config)#router rip

RouterB(config-router)#network 192.168.2.0

RouterB(config- router)#network 192.168.4.0

RouterB(config- router)#end

RouterB#show ip interface brief

查看结果如下:

Router B各端口参数配置情况

(4)配置Router C的端口IP及动态路由。将PC3的串口线连到Router C的Console端口上,打开超级终端,配置好参数,进入到路由器的普通模式,在其命令行输入窗口上输入以下命令。

Router>enable

Password:

Router#conf t

Router(config)#hostname RouterC

RouterC(config)#interface f1/0

RouterC(config-if)#ip address 192.168.3.1 255.255.255.0

RouterC (config-if)#no shutdown

RouterC (config-if)#interface s1/2

RouterC (config-if)#ip address 192.168.5.2 255.255.255.0

RouterC (config-if)#no clock

RouterC (config-if)#no shutdown

RouterC (config-if)#exit

RouterC (config)#ip routing

RouterC (config)#router rip

RouterC (config- router)#network 192.168.3.0

RouterC (config- router)#network 192.168.5.0

RouterC (config- router)#end

RouterC #show ip interface brief

Router A动态路由表(RIP)

②在PC2的超级终端窗口输入以下命令,查看Router B的路由表。 RouterB#show ip route

查看结果如下:

Router B的动态路由表(RIP)

③在PC3的超级终端窗口输入以下命令,查看RouterC的路由表。 RouterC#show ip route

查看结果如下:

Router C的动态路由表(RIP)

(6)验证3个网络之间的连通性。

①打开PC1的DOS窗口(用cmd命令进入),在该窗口上输入以下命令。

C:>\ping 192.168.1.11 (通)

C:>\ping 192.168.2.11 (通)

C:>\ping 192.168.3.11 (通)

②打开PC2的DOS窗口(用cmd命令进入),再该窗口上输入以下命令。

C:>\ping 192.168.1.11 (通)

C:>\ping 192.168.2.11 (通)

C:>\ping 192.168.3.11 (通)

③打开PC3的DOS窗口(用cmd命令进入),再该窗口上输入以下命令。

C:>\ping 192.168.1.11 (通)

C:>\ping 192.168.2.11 (通)

C:>\ping 192.168.3.11 (通)

通过以上测试,如果3个网络互相之间都能PING通,则说明各路由器的动态协议(RIP)配置正确;否则,要返回去检查,查看是否有输入错误的地方。

5.2动态路由协议OSPF配置实验

本实验接上个实验,实验拓扑图不变,不需要改动连线。所有计算机及路由器各端口IP地址均不变,仅需要改变各路由器的动态路由协议(现在各台路由器上执行no router rip命令,用以删除RIP协议)。每台路由器的动态协议OSPF配置如下。

⑴配置RouterA的动态路由协议OSPF。在PC1的超级终端窗口输入以下命令。

RouterA#conf t

RouterA(config)#router ospf 1

RouterA(config-router)#network 192.168.1.0 0.255.255.255 area 0

RouterA(config-router)#end

RouterA#

(2)配置RouterB的动态路由协议OSPF。在PC2的超级终端窗口输入以下命令。 RouterB#conf t

RouterB(config)#router ospf 10

RouterB(config-router)#network 192.168.2.0 0.255.255.255 area 0

RouterB(config-router)#end

RouterB#

(3)配置RouterC的动态路由协议OSPF。在PC3的超级终端窗口输入以下命令。 RouterC#conf t

RouterC(config)#router ospf 20

RouterC(config-router)#network 192.168.3.0 0.255.255.255 area 0

RouterC(config-router)#end

RouterC#

(4)分别查询3个路由器的路由表。

①在PC1的超级终端窗口输入以下命令,查看RouterA的路由表。

RouterA#show ip route

查看结果如下:

②在PC2的超级终端窗口输入以下命令,查看RouterB的路由表。

RouterB#show ip route

查看结果如下:

RouterB的动态路由表(OSPF)

③在PC3的超级终端窗口输入以下命令,查看RouterC的路由表。

RouterC#show ip route

RouterC的动态路由表(OSPF)

(5)验证3个网络之间的连通性。

①打开PC1的DOS窗口,在该窗口上输入以下命令。

C:>\ping 192.168.1.11 (通)

C:>\ping 192.168.2.11 (通)

C:>\ping 192.168.3.11 (通)

②打开PC2的DOS窗口,在该窗口上输入以下命令。

C:>\ping 192.168.1.11 (通)

C:>\ping 192.168.2.11 (通)

C:>\ping 192.168.3.11 (通)

③打开PC3的DOS窗口,在该窗口上输入以下命令。

C:>\ping 192.168.1.11 (通)

C:>\ping 192.168.2.11 (通)

C:>\ping 192.168.3.11 (通)

通过以上测试,如果3个网络相互之间ping通,则说明各路由器的动态协议(OSPF)配置正确,否则,要返回去检查,查看是否有输入错误的地方。

三、实验总结

(1)RIP的15跳限制,超过15跳的路由被认为不可达

RIP不能支持可变长子网掩码(VLSM),导致IP地址分配的低效率

周期性广播整个路由表,在低速链路及广域网云中应用将产生很大问题

收敛速度慢于OSPF,在大型网络中收敛时间需要几分钟

RIP没有网络延迟和链路开销的概念,路由选路基于跳数。拥有较少跳数的路由总是被选为最佳路由即使较长的路径有低的延迟和开销

RIP没有区域的概念,不能在任意比特位进行路由汇总

一些增强的功能被引入RIP的新版本RIPv2中,RIPv2支持VLSM,认证以及组播更新。但RIPv2的跳数限制以及慢收敛使它仍然不适用于大型网络

(2)OSPF更适合用于大型网络

:

没有跳数的限制

支持可变长子网掩码(VLSM)

使用组播发送链路状态更新,在链路状态变化时使用触发更新,提高了带宽的利用率 收敛速度快

具有认证功能

参考文献:

[1]谢希仁编著.《计算机网络(第五版)》.电子工业出版社.2008.1.

[2]肖建良,敖磊,石磊编著.《网络技术实验教程》.清华大学出版社.2009.10.网络工程综合实验

课程设计

题 目 路由协议在组网技术中的应用

院 系 电子工程系

专 业 信息工程

学 号 20092309022

姓 名 杨 金 磊

指导教师 王丽娜

二O一一 年 十二 月 八 日

目 录

一、摘要 ................................................. 3

二、原理简介 .......................................... 4

2.1交换机原理 .................................... 4

2.2路由器简介 .................................... 4

2.2.1 RIP协议 .......................... 4

2.2.2 OSTF协议 .......................... 5

三、实验设计 .......................................... 5

3.1 实验目的 ....................................... 5

3.2 实验背景 ....................................... 5

3.3 实验内容 ....................................... 6

3.4 实验设备 ....................................... 6

3.5 实验步骤 ....................................... 7

四、总结部分及参考文献 ........................ 2

摘要:

随着因特网技术的快速发展,因特网正在人们的日常生活中起到了越来越大的作用。网络技术的发展也极大地推动了企业网和校园网的建设,无论企业网还是校园网的建设对于企业和学校来说都是一项大的工程,必须精心设计、精心施工,做到经济适用,技术先进、开放性能良好、投资强度合理、与国内外网络互联、能长期、稳定运行的高性能的企业网络。目前在组网中各种动态路由协议和算法都已经比较成熟,各种动态路由协议都有各自的优缺点,应用特性和领域都各有不同。本文主要基于动态路由协议在组网技术中的研究。

关键词:

网络技术 动态路由 组网 企业

Summary:

With the rapid development of Internet technology, the Internet is people's daily life has played a growing role. Network technology has greatly promoted the development of the enterprise network and campus network

construction, whether corporate or campusnetwork construction for businesses and schools are a big project, must be carefully designed, well construction, so affordable advanced technology, opening up good performance, reasonable investment intensity, and domestic and international networking,long-term, stable operation of high-performance enterprise networks. Present in a variety of networking protocols and dynamic routing algorithms have been more mature, a variety of dynamic routing protocols have their own advantages and disadvantages, features andareas of application are different. This paper is mainly based on dynamic routing protocolin network technology research.

Keywords:

dynamic routing network enterprise network technologies

一、 原理简介

1. 交换机原理:假设两个使用IP协议的站点A、B通过第三层交换机进行通信,发送站点A在开始发送时,把自己的IP地址与B站的IP地址比较,判断B站是否与自己在同一子网内。若目的站B与发送站A在同一子网内,则进行二层的转发。若两个站点不在同一子网内,如发送站A要与目的站B通信,发送站A要向“缺省网关”发出ARP(地址解析)封包,而“缺省网关”的IP地址其实是三层交换机的三层交换模块。当发送站A对“缺省网关”的IP地址广播出一个ARP请求时,如果三层交换模块在以前的通信过程中已经知道B站的MAC地址,则向发送站A回复B的MAC地址。否则三层交换模块根据路由信息向B站广播一个ARP请求,B站得到此ARP请求后向三层交换模块回复其MAC地址,三层交换模块保存此地址并回复给发送站A,同时将B站的MAC地址发送到二层交换引擎的MAC地址表中。从这以后,当A向B发送的数据包便全部交给二层交换处理,信息得以高速交换。由于仅仅在路由过程中才需要三层处理,绝大部分数据都通过二层交换转发,因此三层交换机的速度很快,接近二层交换机的速度,同时比相同路由器的价格低很多。它是一个带有第三层路由功能的第二层交换机,但它是二者的有机结合,并不是简单地把路由器设备的硬件及软件叠加在局域网交换机上。

2. 路由器原理:路由器是工作在IP协议网络层实现子网之间转发数据的设备。路由器内部可以划分为控制平面和数据通道。在控制平面上,路由协议可以有不同的类型。路由器通过路由协议交换网络的拓扑结构信息,依照拓扑结构动态生成路由表。在数据通道上,转发引

擎从输入线路接收IP包后,分析与修改包头,使用转发表查找输出端口,把数据交换到输出线路上。转发表是根据路由表生成的,其表项和路由表项有直接对应关系,但转发表的格式和路由表的格式不同,它更适合实现快速查找。转发的主要流程包括线路输入、包头分析、数据存储、包头修改和线路输出。路由协议根据网络拓扑结构动态生成路由表。IP协议把整个网络划分为管理区域,这些管理区域称为自治域,自治域区号实行全网统一管理。这样,路由协议就有域内协议和域间协议之分。域内路由协议,如OSPF、IS-IS,在路由器间交换管理域内代表网络拓扑结构的链路状态,根据链路状态推导出路由表。域间路由协议相邻节点交换数据,不能使用多播方式,只能采用指定的点到点连接。

3. RIP(Routing information Protocol)是应用较早、使用较普遍的内部网关 协议(Interior Gateway Protocol,简称IGP),适用于小型同类网络,是典型的距离向量(distance-vector)协议。RIP通过广播UDP报文来交换路由信息,每30秒发送一次路由信息更新。RIP提供跳跃计数(hop count)作为尺度来衡量路由距离,跳跃计数是一个包到达目标所必须经过的路由器的数目。如果到相同目标有二个不等速或不同带宽的路由器,但跳跃计数相同,则RIP认为两个路由是等距离的。RIP最多支持的跳数为15,即在源和目的网间所要经过的最多路由器的数目为15,跳数16表示不可达。

RIP v2 由 RIP v1 而来,属于 RIP 协议的补充协议,主要用于扩大 RIP 2 信息装载的有用信息的数量,同时增加其安全性能。RIP 2 是一种基于 UDP 的协议。在 RIP2 下,每台主机通过路由选择进程发送和接受来自 UDP 端口520的数据包。

4. OSPF是一种分层次的路由协议,其层次中最大的实体是AS(自治系统),即遵循共同路由策略管理下的一部分网络实体。在每个AS中,将网络划分为不同的区域。每个区域都有自己特定的标识号。对于主干(backbone)区域,负责在区域之间分发链路状态信息。这种分层次的网络结构是根据OSPF的实际提出来的。当网络中自治系统非常大时,网络拓扑数据库的内容就更多,所以如果不分层次的话,一方面容易造成数据库溢出,另一方面当网络中某一链路状态发生变化时,会引起整个网络中每个节点都重新计算一遍自己的路由表,既浪费资源与时间,又会影响路由协议的性能(如聚合速度、稳定性、灵活性等)。因此,需要把自治系统划分为多个域,每个域内部维持本域一张唯一的拓扑结构图,且各域根据自己的拓扑图各自计算路由,域边界路由器把各个域的内部路由总结后在域间扩散。这样,当网络中的某条链路状态发生变化时,此链路所在的域中的每个路由器重新计算本域路由表,而其它域中路由器只需修改其路由表中的相应条目而无须重新计算整个路由表,节省了计算路由表的时间。

5.RIP与OSPF协议的比较

目前应用较多的路由协议有RIP和OSPF,它们同属于内部网关协议,但RIP基于距离矢量算法,而OSPF基于链路状态的最短路径优先算法。它们在网络中利用的传输技术也不同。

二、 实验设计

1. 实验目的

掌握配置动态路由的方法,以进一步理解路由器在互联网络中的应用。对路由器转发数据包的过程也可以得到进一步的理解。

2. 实验背景

Internet是由千千万万个路由器互联在一起进行工作的,网络中每一台路由器都运行着种动态协议,以不断学习整个Internet的拓扑结构,更新自身的路由表,使得收到的数据包能收到合适的路径。因此,了解并学会配置路由器的动态协议是一个网络管理员的必修课。为了简化起见,在本实验中,将使用3台路由器来连接3个网络,实现3个网络之间的互联。本实验可设定192.168.1.0为总部的网络号,Router A为该网络的辩解路由器;192.168.2.0为分部1的网络号,Router B为该网络边界路由器;192.168.3.0为分部2的网络号,Router C为该网络的边界路由器。Router A与Router B间的网络其网络号为192.168.4.0;Router A与Router C间的网络其网络号为192.168.5.0.

3. 实验内容

⑴配置动态路由协议RIP实验。

⑵配置动态路由协议OSPF实验。

4. 实验设备

3台计算机,3台路由器,3台交换机,2条DTE/DCE串口线缆,若干跳线。

5. 实验步骤

5.1动态路由协议RIP配置实验

(1)关闭所有路由器电源,按照如图所示的实验拓扑图连线,并配置好各台计算机的IP地址及网关。

Switch B

Router C

F1/0

GW:192.168.1.1 F0/16 (PC2)

Switch C IP:192.168.2.11/24

GW::192.168.2.1 GW:192.168.3.1

动态路由拓扑图

在图中,每台计算机的串口(COM)线都需要连到各自对应的路由器的Console端口上。每台计算机配置各自连接的路由器,小组中每个人合理分工,分别扮演A、B、C角色。

(2)配置Router A的端口IP及动态路由。将PC1的串口线连到Router A的Console端口上,打开PC1的超级终端,配置好参数,进入到路由器的普通模式,然后在其命令行窗口上输入以下黑色斜体字命令。

Router>enable

Password:

Router# conf t

Router(config)#hostname RouterA

RouterA(config)#interface f1/0

RouterA(config-if)#ip address 192.168.1.1 255.255.255.0

RouterA(config-if)#no shutdown

RouterA(config-if)#interface s1/2

RouterA(config-if)#ip address 192.168.4.1 255.255.255.0

RouterA(config-if)#no clock

RouterA(config-if)#no shutdown

RouterA(config-if)#interface s1/3

RouterA(config-if)#ip address 192.168.5.1 255.255.255.0

RouterA(config-if)#clock rate 64000

RouterA(config-if)#no shutdown

RouterA(config-if)#exit

Router(config)#ip routing

Router(config)#router rip

Router(config-router)#network 192.168.1.0

Router(config-router)#network 192.168.4.0

Router(config-router)#network 192.168.5.0

Router(config-router)#end

RouterA#show interface brief

Router A各端口参数配置情况

(3)配置Router B的端口IP及动态路由。将PC2的串口线连到Router B的Console端口上,打开超级终端,配置好参数,进入到路由器的普通模式,在其命令行输入窗口上输入以下命令。

Router>enable

Password:

Router#conf t

Router(config)#hostname RouterB

RouterB(config)#interface f1/0

RouterB(config-if)#ip address 192.168.2.1 255.255.255.0

RouterB(config-if)#no shutdown

RouterB(config-if)#interface s1/2

RouterB(config-if)#ip address 192.168.4.2 255.255.255.0

RouterB(config-if)#clock rate 64000

RouterB(config-if)#no shutdown

RouterB(config-if)#exit

RouterB(config)#ip routing

RouterB(config)#router rip

RouterB(config-router)#network 192.168.2.0

RouterB(config- router)#network 192.168.4.0

RouterB(config- router)#end

RouterB#show ip interface brief

查看结果如下:

Router B各端口参数配置情况

(4)配置Router C的端口IP及动态路由。将PC3的串口线连到Router C的Console端口上,打开超级终端,配置好参数,进入到路由器的普通模式,在其命令行输入窗口上输入以下命令。

Router>enable

Password:

Router#conf t

Router(config)#hostname RouterC

RouterC(config)#interface f1/0

RouterC(config-if)#ip address 192.168.3.1 255.255.255.0

RouterC (config-if)#no shutdown

RouterC (config-if)#interface s1/2

RouterC (config-if)#ip address 192.168.5.2 255.255.255.0

RouterC (config-if)#no clock

RouterC (config-if)#no shutdown

RouterC (config-if)#exit

RouterC (config)#ip routing

RouterC (config)#router rip

RouterC (config- router)#network 192.168.3.0

RouterC (config- router)#network 192.168.5.0

RouterC (config- router)#end

RouterC #show ip interface brief

Router A动态路由表(RIP)

②在PC2的超级终端窗口输入以下命令,查看Router B的路由表。 RouterB#show ip route

查看结果如下:

Router B的动态路由表(RIP)

③在PC3的超级终端窗口输入以下命令,查看RouterC的路由表。 RouterC#show ip route

查看结果如下:

Router C的动态路由表(RIP)

(6)验证3个网络之间的连通性。

①打开PC1的DOS窗口(用cmd命令进入),在该窗口上输入以下命令。

C:>\ping 192.168.1.11 (通)

C:>\ping 192.168.2.11 (通)

C:>\ping 192.168.3.11 (通)

②打开PC2的DOS窗口(用cmd命令进入),再该窗口上输入以下命令。

C:>\ping 192.168.1.11 (通)

C:>\ping 192.168.2.11 (通)

C:>\ping 192.168.3.11 (通)

③打开PC3的DOS窗口(用cmd命令进入),再该窗口上输入以下命令。

C:>\ping 192.168.1.11 (通)

C:>\ping 192.168.2.11 (通)

C:>\ping 192.168.3.11 (通)

通过以上测试,如果3个网络互相之间都能PING通,则说明各路由器的动态协议(RIP)配置正确;否则,要返回去检查,查看是否有输入错误的地方。

5.2动态路由协议OSPF配置实验

本实验接上个实验,实验拓扑图不变,不需要改动连线。所有计算机及路由器各端口IP地址均不变,仅需要改变各路由器的动态路由协议(现在各台路由器上执行no router rip命令,用以删除RIP协议)。每台路由器的动态协议OSPF配置如下。

⑴配置RouterA的动态路由协议OSPF。在PC1的超级终端窗口输入以下命令。

RouterA#conf t

RouterA(config)#router ospf 1

RouterA(config-router)#network 192.168.1.0 0.255.255.255 area 0

RouterA(config-router)#end

RouterA#

(2)配置RouterB的动态路由协议OSPF。在PC2的超级终端窗口输入以下命令。 RouterB#conf t

RouterB(config)#router ospf 10

RouterB(config-router)#network 192.168.2.0 0.255.255.255 area 0

RouterB(config-router)#end

RouterB#

(3)配置RouterC的动态路由协议OSPF。在PC3的超级终端窗口输入以下命令。 RouterC#conf t

RouterC(config)#router ospf 20

RouterC(config-router)#network 192.168.3.0 0.255.255.255 area 0

RouterC(config-router)#end

RouterC#

(4)分别查询3个路由器的路由表。

①在PC1的超级终端窗口输入以下命令,查看RouterA的路由表。

RouterA#show ip route

查看结果如下:

②在PC2的超级终端窗口输入以下命令,查看RouterB的路由表。

RouterB#show ip route

查看结果如下:

RouterB的动态路由表(OSPF)

③在PC3的超级终端窗口输入以下命令,查看RouterC的路由表。

RouterC#show ip route

RouterC的动态路由表(OSPF)

(5)验证3个网络之间的连通性。

①打开PC1的DOS窗口,在该窗口上输入以下命令。

C:>\ping 192.168.1.11 (通)

C:>\ping 192.168.2.11 (通)

C:>\ping 192.168.3.11 (通)

②打开PC2的DOS窗口,在该窗口上输入以下命令。

C:>\ping 192.168.1.11 (通)

C:>\ping 192.168.2.11 (通)

C:>\ping 192.168.3.11 (通)

③打开PC3的DOS窗口,在该窗口上输入以下命令。

C:>\ping 192.168.1.11 (通)

C:>\ping 192.168.2.11 (通)

C:>\ping 192.168.3.11 (通)

通过以上测试,如果3个网络相互之间ping通,则说明各路由器的动态协议(OSPF)配置正确,否则,要返回去检查,查看是否有输入错误的地方。

三、实验总结

(1)RIP的15跳限制,超过15跳的路由被认为不可达

RIP不能支持可变长子网掩码(VLSM),导致IP地址分配的低效率

周期性广播整个路由表,在低速链路及广域网云中应用将产生很大问题

收敛速度慢于OSPF,在大型网络中收敛时间需要几分钟

RIP没有网络延迟和链路开销的概念,路由选路基于跳数。拥有较少跳数的路由总是被选为最佳路由即使较长的路径有低的延迟和开销

RIP没有区域的概念,不能在任意比特位进行路由汇总

一些增强的功能被引入RIP的新版本RIPv2中,RIPv2支持VLSM,认证以及组播更新。但RIPv2的跳数限制以及慢收敛使它仍然不适用于大型网络

(2)OSPF更适合用于大型网络

:

没有跳数的限制

支持可变长子网掩码(VLSM)

使用组播发送链路状态更新,在链路状态变化时使用触发更新,提高了带宽的利用率 收敛速度快

具有认证功能

参考文献:

[1]谢希仁编著.《计算机网络(第五版)》.电子工业出版社.2008.1.

[2]肖建良,敖磊,石磊编著.《网络技术实验教程》.清华大学出版社.2009.10.

范文七:网络工程合同

双方经友好协商达成一致共识,签订此电脑维护合同,具体事项如下。

一、维护范围及内容:

⑴ 该网络工程故障维修 。

⑵ 该工程软件故障维修(包括系统安装,系统还原,系统更新,定期检查,)。

⑶ 网络工程每月一资定期检查。

⑷ 工程应用最新信息传播。

⑸ 提供技术支持。

二、维护方式:

⑴ 突发故障的上门维护:在接到甲方的电话通知后,乙方必须最迟在第二个工作日内进行上门维护。(如有特殊意外,双方调解处理)。

⑵ 每周一次定期探访维护系统,对用户的系统进行优化配置、调试好应用软件及相关硬件设备,使系统达到更高使用效率。

三、收费:

项目实施完毕后一年内免费提供产品及工程的维护和检查,终身优惠提供 项目升级及维护。

四、双方责任。

⑴.在甲方的工作时间内必须尽职尽责提供工程维护项目里的服务内容,甲方要求服务的联系方式为电话联系,甲方发出维护请求后,乙方必须在20—120分钟内上门服务,如有特殊意外,双方调解处理。

⑵.乙方在为甲方硬件维护的过程当中,如碰到硬件寿命终止或无法维修时,由甲方自出更换新配件或是可用配件费用(其中更换零配件负责安装费用属于免收范围)。如甲方被维修的配件为乙方所提供,则根据产品正规保修细则履行。

⑶.乙方在为甲方更新系统、工程服务的过程当中如碰到必须购买必要特殊的工具或软件,其费用由甲方支付。

五、合同未尽事宜,由甲乙双方另议。

六、本合同书一式两份,双方各持一份

七、本合同双方签字盖章后生效。

甲方:(盖章)乙方:(盖章)

代表人:代表人:

年月日年月 日

======

甲方:_________

法定代表人:___

乙方:_________

法定代表人:___

丙方:_________

法定代表人:___

本_________小额支付系统合同由上列各方于_________年_________月_________日在_________市订立。

鉴于甲乙丙三方就_________小额支付系统网络工程项目的事宜,三方经协商一致,达成_________小额支付系统合同,合同如下:

第一条 甲方、乙方和丙方

甲方_________,乙方_________以及丙方_________三方就_________小额支付系统网络工程项目签订本合同。本合同所有采购货物和软件应用于_________小额支付系统网络工程。

第二条 法定地址

甲乙丙三方就本合同进行的一切正式联系,除另有商定外,均应使用以下地址:

甲方:_________

地址:_________

邮编:_________

电话:_________

传真:_________

联系人:_______

乙方:_________

地址:_________

邮编:_________

电话:_________

传真:_________

联系人:_______

开户行:_______

帐号:_________

丙方:_________

地址:_________

邮政编码:_____

电话:_________

传真:_________

联系人:_______

第三条 定义

本合同词组,将具下列特定含义:

工程:指本合同项下要求乙方为甲方、丙方提供的产品和服务的总和。

服务:指本合同项下由乙方提供的培训、安装及所有测试、调试、检验和技术支持等。

范文八:网络工程合同

委托方(甲方):________________________________

承建方(乙方):________________________________

经双方协商,订立合同如下:

一、服务内容

1.甲方同意乙方来承建甲方的网络工程,在承建过程中,乙方会按照甲方的要求的时间内完成乙方销售给甲方的设备的安装和调试,甲方承担配合乙方进行安装和调试的各项工作。

2.经双方协商,乙方的施工开始日期为____年____月____日,交工日期为____年____月____日。

3.网络工程项目明细:

甲方局域网布线由第三方承包商承建,乙方负责布线完成之后的机房网络设备安装及调试工作。

在第三方承包商布线及测试完成的前提下,乙方负责实施甲方办公场地的计算机网络节点的安装及调试工作(不包含网络布线和线路测试)。

线路故障引起的网络问题由布线承包商解决,不在我公司责任范围,设备故障问题在我公司责任范围内,由我公司解决。

二、质量保证及保修

甲方承担线路调试所需的施工费及设备购置费(网线,交换机,路由器)。

乙方对其销售的产品提供____年质保(交换机),对工程所涉及的线路及设备保修期限为自交工之日起____年。(硬件保修____年,人为损坏无质保)对保修范围内的硬件,乙方不收取任何费用。

对于计算机病毒或计算机操作系统自身故障造成的网络不通或其他网络故障不在保修范围,对于此类故障乙方可以配合甲方进行维修及维护工作,但要收取相应的人工费。

三、合同报价

合同报价见附件“网络工程报价明细”。

四、付款方式

合同签订之日,甲方向乙方预付工程总价的____作为订金,设备到达后付给乙方工程总价的? 设备款,余款在工程验收通过之后由甲方向乙方以现金方式一次性付清。

五、违约条款

合同自甲乙双方签定之日起生效,合同期自签订之日起至交工之日起一年。在合同期内任何一方违反合约。违约方须向被违约方赔偿违约金人民币____元。

本合同未尽事项和条款,由甲乙双方协商解决。

本合同如有争议,由双方协商解决,协商不成,交由____人民法院解决。

本合同一式两份,甲乙双方各执一份,自签署之日起生效。

甲方:________________

甲方代表:____________

地址:________________

邮编:________________

电话:________________

开户行:______________

帐号:________________

________年_____月___日

乙方:________________

乙方代表:____________

地址:________________

邮编:________________

电话:________________

开户行:______________

帐号:________________

________年_____月___日

范文九:网络工程合同

双方经友好协商达成一致共识,签订此电脑维护合同,具体事项如下。

一、维护范围及内容:

⑴ 该网络工程故障维修 。

⑵ 该工程软件故障维修(包括系统安装,系统还原,系统更新,定期检查,)。

⑶ 网络工程每月一资定期检查。

⑷ 工程应用最新信息传播。

⑸ 提供技术支持。

二、维护方式:

⑴ 突发故障的上门维护:在接到甲方的电话通知后,乙方必须最迟在第二个工作日内进行上门维护。(如有特殊意外,双方调解处理)。

⑵ 每周一次定期探访维护系统,对用户的系统进行优化配置、调试好应用软件及相关硬件设备,使系统达到更高使用效率。

三、收费:

项目实施完毕后一年内免费提供产品及工程的维护和检查,终身优惠提供 项目升级及维护。

四、双方责任。

⑴.在甲方的工作时间内必须尽职尽责提供工程维护项目里的服务内容,甲方要求服务的联系方式为电话联系,甲方发出维护请求后,乙方必须在20—120分钟内上门服务,如有特殊意外,双方调解处理。

⑵.乙方在为甲方硬件维护的过程当中,如碰到硬件寿命终止或无法维修时,由甲方自出更换新配件或是可用配件费用(其中更换零配件负责安装费用属于免收范围)。如甲方被维修的配件为乙方所提供,则根据产品正规保修细则履行。

⑶.乙方在为甲方更新系统、工程服务的过程当中如碰到必须购买必要特殊的工具或软件,其费用由甲方支付。

五、合同未尽事宜,由甲乙双方另议。

六、本合同书一式两份,双方各持一份

七、本合同双方签字盖章后生效。

甲方:(盖章)乙方:(盖章)

代表人:代表人:

年月日年月 日

======

甲方:_________

法定代表人:___

乙方:_________

法定代表人:___

丙方:_________

法定代表人:___

本_________小额支付系统合同由上列各方于_________年_________月_________日在_________市订立。

鉴于甲乙丙三方就_________小额支付系统网络工程项目的事宜,三方经协商一致,达成_________小额支付系统合同,合同如下:

第一条 甲方、乙方和丙方

甲方_________,乙方_________以及丙方_________三方就_________小额支付系统网络工程项目签订本合同。本合同所有采购货物和软件应用于_________小额支付系统网络工程。

第二条 法定地址

甲乙丙三方就本合同进行的一切正式联系,除另有商定外,均应使用以下地址:

甲方:_________

地址:_________

邮编:_________

电话:_________

传真:_________

联系人:_______

乙方:_________

地址:_________

邮编:_________

电话:_________

传真:_________

联系人:_______

开户行:_______

帐号:_________

丙方:_________

地址:_________

邮政编码:_____

电话:_________

传真:_________

联系人:_______

第三条 定义

本合同词组,将具下列特定含义:

工程:指本合同项下要求乙方为甲方、丙方提供的产品和服务的总和。

服务:指本合同项下由乙方提供的培训、安装及所有测试、调试、检验和技术支持等。

产品:指硬件、软件和卡片。

硬件:指在本合同项下,由乙方提供的设备、材料和合同规定的技术文件(包括设备安装、运行和维修所需图纸和手册)。

软件:指在本合同项下,由乙方提供的程序和任何其他由乙方按本合同规定增加或替换的程序。

合同价格:指当乙方在全面正确地履行本合同义务的情况下,按本合同规定甲方应支付乙方的价格。

工地:指系统安装所在地。

三方:指甲方、乙方、丙方之统称。

第四条 工程范围

经丙方组织和工程全程监督,甲方同意采购,乙方同意提供设备、软件及服务以建设_________小额支付系统网络工程。

本工程简述如下:

1.丙方受甲方委托,对工程项目进行可行性论证,组织系统集成商对工程项目招标,征求甲方意见后,确定乙方为工程项目的系统集成商,并对整个工程项目的实施进行工程管理控制和技术把关。

2.乙方提供整套全新的产品,并负责进行安装和测试,使系统正常运行。乙方所提供的产品详见附件。

3.由乙方提供及保证系统之技术性能、质量及提供服务支持。

4.乙方应在工地进行工程的安装,并在甲方、丙方参与下实施系统完工测试和调试。

5.乙方须按要求对甲方技术人员提供培训。

6.除以上二、三、四项由乙方负责外,甲方负责_________及POS机具的建设与投入、安装调试;甲方所提供产品须符合乙方及丙方的技术要求,保证与乙方负责的工程建设部分的良好对接,成功运行;并保证符合丙方的行业要求。

7.丙方提供整套系统相配套的网络建设,督促_________按时完成_________网络建设,并将相关接口按时提供给甲方和乙方。

第五条 合同的文件

以下文件将构成合同的组成部分:

1.本合同共_________页。

注:所有技术及功能要求以乙方提供的系统方案建议书之描述和最终用户的需求为准。

2.合同附件,包括硬件设备和软件清单及价格组成,与本合同为一整体。

第六条 价格

设备及系统(内容详见清单)安装费用_________元,卡片费用_________张共_________元,总计:_________元(大写:_________圆整)。

第七条 履行

本合同系统工程的履行均由四个阶段组成,包括程序设计及生产、安装调试、试运行及初步验收、技术服务。

1.程序设计及生产阶段:乙方在收到本合同规定的预付款后,应根据合同附件的要求,开始组织产品的开发及生产工作,上述工作应于乙方收到预付款之日起_________天内完成。

2.安装调试阶段:在上述规定的交付日期前,由乙方直接向甲方交付经丙方审核的本合同所述产品,并派出专人上门进行安装调试。

3.试运行及初步验收阶段:安装调试完毕后,即开始为期壹个月的试运行期,在试运行期结束后一周内,甲方应会同丙方对工程进行书面的初步验收并出具验收报告,超过一周不通知乙方视为初步验收合格。

4.技术服务阶段:在甲方、丙方对产品初步验收合格后_________年内,乙方应对其产品向甲方提供免费的技术服务,确保为甲方提供优质的售后服务。

第八条 在完成施工和生产后,由乙方向甲方提供本合同相应金额的合法发票。

第九条 设备及系统付款方式

甲方先付_________元人民币作为乙方的项目启动资金,乙方收到该笔货款后开始整个项目的设计及施工,系统完工并由甲方初步验收合格后_________个月内付_________元,余额在初步验收合格后_________年内付清。

第十条 卡片付款方式

乙方按项目需求进行分批生产,生产周期为甲方及银行定稿后_________周左右到货,每批次卡片不小于_________张。甲方在收到卡片并验收合格后,一个月内支付_________%的相应货款,余额在验收合格后_________天内付清。卡片验收期限为_________周,超过_________周甲方未通知乙方视为验收合格。

第十一条 丙方负责本合同中支付条款的落实和监督,甲方未能履行支付责任,丙方负有连带责任。

第十二条 乙方有责任派遣熟练和合格的技术专家以培训甲方和丙方的技术人员和解释合同范围内所有相关技术问题,以使甲方的操作、安装和维护人员可以清楚产品的配置、性能以及安装程序和维护标准,并掌握操作、维护和应付紧急事件的方法。

第十三条 培训地点与培训时间

在每期工程安装调试后在工地进行,为期_________周。

第十四条 培训费用

在工程正式验收前,产品提供方免费对甲方和丙方技术人员进行培训。在甲方、丙方对工程正式验收合格后,若甲方需要乙方继续为其工作人员提供培训服务的,应向乙方支付一定的培训费用,具体数额另行约定。

第十五条 试运行与初步验收阶段

1.在试运行阶段,甲方和丙方应根据合同附件的规定及性能标准对产品进行测试,若产品能基本符合上述要求,并能稳定运行,则甲方、丙方应对产品进行初步验收。

2.若产品没有通过初步验收的,乙方应在_________个月内排除故障,并重新开始试运行期。

第十六条 正式验收

1.验收标准:甲方、丙方应根据合同附件_________的规定进行验收。

2.验收时间及方法:甲方、丙方根据本合同规定进行初步验收后半年内须对工程进行正式验收,经验收合格的应出具书面验收确认书。若发现工程存在任何不符合验收标准的问题,应在上述验收期内以书面方式提出。

3.若逾期未提出任何书面异议的,视为验收合格。

第十七条 电话咨询

在产品正式投入运行后,若甲方在使用过程中遇到任何疑难问题,乙方应通过提供的热线电话向甲方进行咨询,由乙方的专业技术人员为甲方解答各种疑难,电话响应时间不超过_________小时。

第十八条 上门服务。

在产品正式投入运行后,若甲方在使用过程中遇到仅通过电话咨询无法解决的问题,乙方应根据具体情况,尽快派出专业技术人员上门提供技术服务。若是过了产品保修期后,由此产生的相关费用由甲方负责。

第十九条 乙方向甲方提供之设备的保修内容及保修期限,以设备原厂商的保修承诺为准,但由于甲方或其客户保管或使用不当而造成的损坏,乙方不予负责,若需进行维修,则由甲方支付相关费用。

第二十条 在上述免费技术服务期满后,乙方可向甲方提供有偿的技术服务,具体费用另行约定。

第二十一条 合同的解除。

1.合同各方经共同协商一致,可解除本合同,但解除协议必须以书面形式作出,并由合同各方共同签字确认。

2.当出现法律规定的情形时,可解除本合同,但解除协议一方必须以书面形式通知对方。

3.解除合同的后果。非因乙方原因导致合同解除的,若乙方已根据本合同履行了全部或部分义务,则甲方有义务向乙方支付全部或部分的合同价格。

第二十二条 违约责任

若因可归责于乙方的原因致使其未能按时向甲方提供本合同所述产品的,或因可归责于甲方的原因致使其未能按时付款的,每迟延1日违约方应向守约方支付相当于合同价格万分之_________的迟延履行违约金。

第二十三条 陈述和保证

1.甲方的陈述和保证。甲方向各方陈述和保证如下:

(1)其是一家依法设立并有效存续的有限责任公司;

(2)其有权进行本合同规定的行为,并已采取所有必要的公司行为授权签订和履行本合同;

(3)本合同自签定之日起对其构成有约束力的义务。

2.乙方的陈述和保证。乙方向各方陈述和保证如下:

(1)其是一家依法设立并有效存续的有限责任公司;

(2)其有权进行本合同规定的行为,并已采取所有必要的公司行为授权签订和履行本合同;

(3)本合同自签定之日起对其构成有约束力的义务。

3.丙方的陈述和保证。 丙方向各方陈述和保证如下:

(1)其是一家依法设立并有效存续的农村信用合作社;

(2)其有权进行本合同规定的行为,并已采取所有必要的行为授权签订和履行本合同;

(3)本合同自签定之日起对其构成有约束力的义务。

第二十四条 保密

一方对因_________小额支付系统合同而获知的另一方的商业机密负有保密义务,不得向有关其他第三方泄露,但中国现行法律、法规另有规定的或经另一方书面同意的除外。

第二十五条 补充与变更

本合同可根据各方意见进行书面修改或补充,由此形成的补充协议,与合同具有相同法律效力。

合同各方经共同协商一致,可对本合同内容进行变更,但该变更必须以书面形式作出,并由合同各方共同签字确认。

第二十六条 合同附件

1.本合同附件包括但不限于:

各方签署的与履行本合同有关的修改、补充、变更协议;

各方的营业执照复印件、及相关的各种法律文件;

2.任何一方违反本合同附件的有关规定,应按照本合同的违约责任条款承担法律责任。

第二十七条 不可抗力

任何一方由于诸如战争、严重火灾、洪水、台风、地震、核污染或事故,或其它任何一方无法合理控制的,并在合同当日或之后严重影响合同履行的,则合同执行时间得根据受影响的时间相应延长。但是,合同价格不得因不可抗力而调整。

任何一方因有不可抗力致使全部或部分不能履行本合同或迟延履行本合同,应自不可抗力事件发生之日起三日内,将事件情况以书面形式通知另一方,并自事件发生之日起三十日内,向另一方提交导致其全部或部分不能履行或迟延履行的证明。

第二十八条 争议的解决

本合同适用中华人民共和国有关法律,受中华人民共和国法律管辖。

本合同各方当事人对本合同有关条款的解释或履行发生争议时,应通过友好协商的方式予以解决。如果经协商未达成书面协议,三方同意提交申请仲裁。

第二十九条 权利的保留

任何一方没有行使其权利或没有就对方的违约行为采取任何行动,不应被视为对权利的放弃或对追究违约责任的放弃。任何一方放弃针对对方的任何权利或放弃追究对方的任何责任,不应视为放弃对对方任何其他权利或任何其他责任的追究。所有放弃应书面做出。

第三十条 通知

1.本合同要求或允许的通知或通讯,不论以何种方式传递均自被通知一方实际收到时生效。

2.前款中的“实际收到”是指通知或通讯内容到达被通讯人(在本合同中列明的住所)的法定地址或住所或指定的通讯地址范围。

3.一方变更通知或通讯地址,应自变更之日起三日内,将变更后的地址通知另一方,否则变更方应对此造成的一切后果承担法律责任。

第三十一条 合同的解释

本合同各条款的标题仅为方便而设,不影响标题所属条款的意思。

第三十二条 生效条件

本合同自三方的法定代表人或其授权代理人在本合同上签字并加盖公章之日起生效。有效期至本合同所述工程项目完成时止。各方应在合同正本上加盖骑缝章。本合同一式_________份,具有相同法律效力。各方当事人各执_________份,其他用于履行相关法律手续。

甲方(盖章):_________     乙方(盖章):_________

代表人(签字):_______     代表人(签字):_______

_________年____月____日     _________年____月____日

丙方(盖章):_________

代表人(签字):_______

_________年____月____日

范文十:网络工程导论

合肥学院

课名:网络工程导论

论文名:网络工程专业导论

报告人:

学号:1104032011

班级:网络工程(二)班

指导老师:袁暋老师

2011年11月18日

网络工程专业导论

高考之后我发现填志愿真的很难,对许多院校及专业都不了解,甚至无从下手。我的志愿是在我的表姐的帮助下填的,合肥学院是我的第二志愿,网络工程专业好像是第五个专业,记得不太清楚了。拿到通知书时,我很高兴,也有点茫然,因为我是来自农村的孩子,之前很少接触网络方面的知识,学校也没有开设相关的课,对自己即将要学的专业,甚至是以后要走得路都不清楚。在暑假期间我尝试的去了解有关本专业的知识,虽然有点收获但是还是谈不上了解。带着迷惑我走进了我一直向往的大学。

当我拿到课表的时候我很高兴,因为有一门课程《网络工程导论》它可以解决我的疑惑。经过了两位资深的专家的介绍和袁老师的精心引导以及自己在网上查询有关资料之后,我对本专业也有了初步的认识,对自己要学习的课程和应掌握的技能有了初步的了解。知道了自己以后发展的方向,对自己的职业生涯进行了初步的规划。这肯定有些不对的地方,因为我毕竟是刚入校的大一新生。

下面是我对本专业的认识,本专业应上得课程,本专业就业方向,以及本人的职业生涯规划。

一、网络工程专业在IT领域中的位置:

随着计算机的远程信息化处理应用的高速发展和广泛应用,网络已成为经济发展的强大动力。网络工程是计算机技术和通信技术密切结合而形成的新兴的技术领域,尤其在当今互联网迅猛发展和网络经济蓬勃繁荣的形势下,网络工程技术成为信息技术界关注的热门技术之一,也是迅速发展并在信息社会中得到广泛应用的一门综合性学科。在IT企业的巨大需求下,信息化浪潮传统企业对网络人才的需求正呈爆炸式增长。近几年,在政府和企业办公网络化的推动下,需要配备大量的网络应用、网络管理人才,对网络人才的需求明显增加。据工业和信息化部预测,今后5年,我国从事网络建设、网站应用及网络服务的新型网络人才需求将达60万—100万人,而现有符合新型网络人才要求的人还不足20万。在我国信息化建设的过程中,网络工程技能方面人才的培养尤为重要。所以本专业在IT领域还是有较高地位的。

二、网络工程专业主要课程:

高等数学、线性代数、概率与统计、离散数学、电路与电子学、数字逻辑电路、数据结构、编译原理、操作系统、数据库系统、汇编语言程序设计、计算机组成原理、微机系统与接口技术、通信原理、通信系统、计算机网络、现代交换原理、TCP/IP原理与技术、计算机网络安全、计算机网络组网原理、网络编程技术、计算机网络管理、网络操作系统、Internet技术及应用、软件工程与方法学、数字信号处理、网格计算技术、计算机系统结构、计算机基础与操作应用、计算机组装维修与局域网构建、计算机网络工程、电子商务、Cisco CCNA网络工程、REDHAT Linux操作系统、计

算机网络安全分析管理、WEB网站设计、SQL Server数据库编程与管理、ASP商务网站与企业应用系统开发、VB企业应用系统开发、.NET编程与系统开发。

三、网络工程专业应有的知识及技能:

网络工程专业培养的人才主要分为科研型、工程型和应用型三个层次,且应具有以下五方面的技能。

(1) 网络设备的设计与制造技术

掌握网络交换机、路由器、防火墙、网络存储、网闸、网关等网络设备的体系结构、工作原理、设计方法、制造工艺等相关技术。

(2) 网络协议的设计与实现技术

掌握包括局域网协议、广域网协议、TCP/IP协议、网络安全协议、网络管理协议及其他网络新应用协议等的工作原理、协议标准描述、协议分析与设计、协议实现、协议测试与验证等相关技术。

(3) 网络应用系统的设计与开发技术

掌握包括C/S模式和B/S模式的网络编程技术、基于网络的MIS系统的设计与开发技术、Web系统与技术、网络多媒体技术、网络分布处理技术、网格计算与云计算技术、网络备份与恢复技术、P2P网络技术、.NET技术、J2EE技术等在内的网络应用系统设计与开发技术。

(4) 网络系统的规划设计与施工技术

掌握网络拓扑结构的设计、网络路由的设计、网络服务的部署、网络可靠性与安全性方案的设计与实施、子网与IP地址的规划、综合布线方案、网络施工方案以及网络测试与验收方案设计、论证等技术。

(5) 网络系统的管理与维护技术

掌握网络设备与系统的配置管理、故障管理、性能管理、安全管理、计费管理、网络性能评价与优化、网络安全防范等技术。

其中(1)、(2)属于科学研究型人才。(3)、(4)属于工程型人才。(5)属于应用型人才。因为我校属于工程应用型大学。所以我主要学习后三种技能,前两种技能也要做相应的了解。

四、网络工程专业就业前景:

(1) 可视化编程

掌握程序设计方法及可视化技术,精通一种可视化平台及其软件开发技术。获取

Delphi程序员系列、Java初级或VB开发能手认证。就业方向:企业、政府、社区、各类学校等可视化编程程序员。

(2) WEB应用程序设计

具有美工基础和网页动画设计能力,掌握交互式网页程序的设计技术,能进行网站建设和维护。获取Macromedia多媒体互动设计师或Delphi初级程序员或Delphi快速网络开发工程师认证。就业方向:企业、政府、社区、各类学校等WEB应用程序员。

(3) 软件测试

掌握软件测试的基本原理、方法和组织管理,精通软件测试工具。获取ATA软件测试工程师或Delphi初级程序员或Java初级程序员认证。就业方向:企业、政府、社区、各类学校等软件测试员。

(4) 数据库管理

能应用关系范式进行数据库设计,精通SQL语言,胜任数据库服务器管理与应用工作。获取Oracle数据库管理或SQL Server数据库应用或Windows XP应用认证。就业方向:企业、政府、社区、各类学校等部门的中、大型数据库管理员。

(5) 图形图像制作

精通国际上流行的图形/图像制作工具(如CorelDraw、Photoshop、Pagemaker等)。获取平面设计师相关的认证。就业方向:广告制作公司、建筑设计公司、包装装璜设计公司、居室装修公司、出版印刷公司。

(6) 网络构建技术

熟悉网络结构和组网方式,掌握建网方法,能利用工具分析和排除常见网络故障。获取Cisco路由配置或华为网络工程或AMP应用工程师认证。就业方向:企业、政府、社区、各类学校等网络构建工程师

五、网络工程专业就业方向:

网络工程师、计算机维修工程师。网络管理员、信息系统维护员、数据库管理、网络安全师、网络存储、路由调试师、Windows服务器管理、、综合布线、网络设备调试、PHP网站开发(商务网站开发、企业网站建设、政府网站建设、在线支付类网站开发)、网络推广员、网站优化SEO、项目经理。

六、本人就业目标:

网络安全工程师

现在,网络安全工程师的就业职位很广泛,总结下来主要有网络安全工程师、网络安全分析师、数据恢复工程师、网络构架工程师、网络集成工程师、网络安全编程工程师。

网络安全工程师工作内容:

(1)分析网络现状。对网络系统进行安全评估和安全加固,设计安全的网络解决方案;

(2) 在出现网络攻击或安全事件时,提高服务,帮助用户恢复系统及调查取证;

(4) 针对客户网络架构,建议合理 的网络安全解决方案;

(4) 负责协调解决方案的客户化实施、部署与开发,推定解决方案上线;

(5)负责协调公司网络安全项目的售前和售后支持。

七、职业生涯规划:

(1)在大学四年里扎扎实实的学好公共基础课和专业课。由于本人不善于交际所以以后积极参加校园活动从而锻炼自己的交际能力,这也是人生的必修课。积极配合老师的教学,按要求完成老师布置的任务,在课余时间看看有关本专业的课外书。总之从各方面锻炼自己,提高自己各方面的能力为走向社会打下良好的基础。

(2)本人打算在大二把英语四级证书拿到手,至于六级就看自己的能力再做打算。

(3)本人不打算考研,因为我政治和英语偏差,所以我的目标是考思科证书,在大三之前争取把CCNA,CCNP证书拿到手。至于CCIE难度太大,所以本人选择先就业,然后看情况决定是否参加CCIE的考试。

(4)毕业后首先在小型企业从事网络信息安全工作。通过实践对网络信息安全有较为完整的认识,掌握电脑安全防护、网站安全、电子邮件安全、Intranet网络安全部署、操作系统安全配置、恶意代码防护、常用软件安全设置、防火墙的应用等技能。

然后在一家中型企业仍然从事网络信息安全工作,使自己得到充分的锻炼。目标能够完善和优化企业信息安全制度和流程,能够对系统中安全措施的实施进行了跟踪和验证,能够建立起立体式、纵深的安全防护系统,部署安全监控机制,对未知的安全威胁能够进行预警和追踪。

有了足够的工作经验和能力之后,进入大型企业工作,俗话说活到老学到老,所以我不能停止自己学习的步伐,在工作中要求自己能够针对安全策略、操作规程、规章制度和安全措施做到程序化、周期化的评估、改善和提升,能够组织建立本公司的信息安全体系。信息安全管理能够结合本公司的具体情况,制定合适的管理制度和流程,并能提出信息安全管理理念,推广到本公司中具体管理活动中。在技术能力上,对本公司的系统中安全措施能够总体上把关,掌握防护系统的脆弱性分析方法,能够提出安全防护系统的改进建议。

熟悉信息安全行业标准和产品特性,熟悉信息安全技术发展动向,针对本公司信息安全需求,能够选择合适安全技术和产品。

网络发展飞速,所以我也要不断学习,否则有一天我会这社会被淘汰。

以上是我个人对网络工程专业的认识及个人职业生涯规划。只有认真学好每一门课,打好基础,才会拥有美好的明天!

致 谢

感谢袁老师的精心引导,和同学们的帮助,使我对本专业有了初步的认识,不再像以前一样迷茫。使我有了自己的目标和方向,这样学习才会有动力。这是我走好大学的第一步。再次感谢袁老师!